Upgraded logstash 1.5 to 5.2, now it doesn't read


(Daniel) #1

Hi everyone. I'm a bit of a newbie with logstash so I hope you could help me with this issue.
I have this customer who uses AWS Beanstalk and has logstash on those instances. They were using logstash 1.5 and I recently updated that to 5.2.

The input is the /var/log/messages file and I added the following output:

file {
path => "/tmp/logstash.out"
}
stdout {
codec => rubydebug
}

But logstash doesn't create the output file and I get no stdout output. I am writing test lines into the messages file (and it's updated quite frequently by the OS), so it's not a case of an untouched file.

I tried running logstash using initctl, and then tried /usr/share/logstash/bin/logstash -f logstash.conf -config.reload.automatic

EDIT: Also, the logs in /var/log/logstash aren't being written to. I set the log.level to debug but still nothing there, not even when I restart the logstash service, which I assume should be mentioned in the log.

I feel really lost here, I'd appreciate any help. Thanks,
Daniel


(Magnus B├Ąck) #2

Sounds like a permissions issue. Make sure the user that Logstash runs as has rwx permissions in /var/log/logstash.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.