Upgrading Kibana to 6


I tried to upgrade kibana using the documentation(https://www.elastic.co/guide/en/kibana/6.0/migrating-6.0-index.html) but I can't create the .kibana-6 index.

this is the error message:

{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"Rejecting mapping update to [.kibana-6] as the final mapping would have more than 1 type: [doc, type1]"}],"type":"illegal_argument_exception","reason":"Rejecting mapping update to [.kibana-6] as the final mapping would have more than 1 type: [doc, type1]"},"status":400}

In this case it seems, that the request you actually send to Kibana, still contains some type1 type besides the doc type. Could you please check your query again, and compare it to the one in the documentation? There should only be the doc type in there, and no further type. Also the index should not exist beforehand.

I deleted the index beforehand, just to see if it exists or not, and copied the query from the documentation with the "copy as curl"-button.

Could you try executing a curl <yourES:9200>/.kibana-6/_mappings and post the output of that, and also paste the exact command you executed here (best a screenshot of the command and the response), please.

{"error":{"root_cause":[{"type":"index_not_found_exception","reason":"no such index","resource.type":"index_or_alias","resource.id":".kibana-6","index_uuid":"_na_","index":".kibana-6"}],"type":"index_not_found_exception","reason":"no such index","resource.type":"index_or_alias","resource.id":".kibana-6","index_uuid":"_na_","index":".kibana-6"},"status":404}

Hi, could you please share the same for the migration query, that causes the error?

There you go. A scrollshot like on my smartphone would be handy for stuff like that :smiley:

Thanks for providing this. I don't see any obvious error and that looks rather weird to me.

@tylersmalley Could someone from the operations team have an idea, where the type1 comes from in this request when executing against an non existing mapping?

Still no answer?

I found out that I had a rogue template.
When we got elasticsearch we tried ourselves at templates and template_1 from the documentation(https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-templates.html) caused my problem.

@timroes thank you for your help

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.