Uploading more than 15 engines in meta engine

I have a set of more than 15 engines that I've created in elastic app search and I want to create a meta engine with them. Is there any way I can increase the capacity of the meta engine?

If the capacity can't be increased, then is there a way to merge indices that are contained within the engines into one common index in order to ensure that the meta engine can be created without any hassles?

Hi @mansi_raval , welcome to the community!

Indeed, you can change configuration to increase the limit of engines per meta engine.

The app_search.engine.source_engines_per_meta_engine.limit is the setting you're looking for.

To merge indices, you can use Elasticsearch Reindex API.

I read the configuration documentation but I found it to be a bit confusing. Can you please help me out with a step-wise set of instructions to execute the solution you provided ? The specific issue that I'm facing is that when I navigate to the Elastic Services Console and then to the Edit section I'm only able to view Elasticsearch, Kibana, Integrations Server and Enterprise Search. I can't seem to find App Search. Also when I clicked on "Edit user settings", and copy pasted the following that you suggested (app_search.engine.source_engines_per_meta_engine.limit), I received an error as follows The YAML settings are invalid, please check your syntax

Hi @mansi_raval !

App Search is part of Enterprise Search, so that's where you should edit the user settings.

Once you're modifying user settings, pasting the following:


Should set meta engines engine limit to 20.

Keep in mind that you need to save your settings after you close the Edit User settings configuration screen.

Hope this helps!

I implemented the solution that you provided but I'm getting the same error and I'm unable to view the save option.

After reading the below instructions (the one provided in the user settings console)* , I read the documentation, however, in this particular instruction - ( 4. In the Enterprise Search section, select Edit user settings. For deployments with existing user settings, you may have to expand the Edit enterprise-search.yml caret instead.) I'm unable to view the Edit enterprise-search.yml option.

*( Note that the syntax for user settings can change between major versions.
You might need to update these user settings before performing a major version upgrade.
To learn more, see the documentation. )

Hi @mansi_raval :

The following steps should be done for changing user settings:

  1. From Edit your deployment, choose Edit User Settings:

  1. Change the appropriate user setting, and then click "Back":

  1. Save your changes

This is what is getting displayed when I implement the above steps :

and when I click on Back and Save, this is error that is displayed :

Could this be due to the version of the enterprise search?

I think you need to use a space after the colon:

app_search.engine.source_engines_per_meta_engine.limit: 20

Yep! it works now! Thanks a ton :slight_smile:
That was a basic error from my end...sorry about that.
Thanks for the help!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.