Urgent Help Installing Kibana!

Hello everyone,

I need your help please.

I'm trying to install kibana to test something (will mention it below) on my laptop.

I cannot access http://localhost:5601. It fails to load.

I also get this when I try to run kibana:

How do I get it starting on my laptop?

The purpose of my installation is to add kibana to SolarWinds Orion web interface, exactly as it appears in the image below:

Will you please be able to guide me as to what I need to do - in kibana and SolarWinds - to get it running inside the web interface as shown in the image?

I would immensely appreciate your quick support!

Thank you,

You need to install the ElasticSearch backend for it to work. You can install the docker image: https://github.com/elastic/elasticsearch-docker

The "no living connections" error means it can't find an ES instance.

I downloaded it and ran the ES file in the bin, this is what I got:

Any help?

I've only ever done it via docker run command. You will need to install docker and then have docker download, install, and run the ES docker file.

I'm not sure what that command is inside the bin.

I'm anything but good at coding/building Dockerfiles.
Could you please give me quick points as to what I need to do?

You'd save my life!

Check out this post:

That'll get you going using docker images locally. I'm running on a Mac and the installation was super quick and easy. Basically get Docker installed on your system then use the Elastic docker image to get ES running on your machine.

Okay so, with the help of a friend, I was able to download and docker run it.
Nothing really changed much.
I still got the "no living connections" thing.

What do I do now?

Hey there, you can also try creating this docker-compose.yml file, cd into the directory which contains this file, and run docker-compose up. This should run Elasticsearch, Kibana, Logstash, and a few Beats. Please let me know if this helps!


hello dear, I did as you said, now I'm stuck in this loop:

These messages won't stop, it's been almost an hour.
What shall I do?

Those messages are there just to show that Kibana, Filebeat, Metricbeat, Packbeat, and Heartbeat are active and generating network activity. Have you tried visiting http://localhost:5601?

BTW, I'm not sure if you've already seen this, but here are links to our official Docker documentation:


I'm going crazy with this.

I'm trying this command:

docker run -p 9200:9200 -e "http.host=" -e "transport.host=" docker.elastic.co/elasticsearch/elasticsearch:5.2.2

nothing is working.

I juuuuust want to be able to access Kibana / ElasticSearch on the localhost:5601. That's all.
I can take it from there.

I tried to log in localhost:9200, and entered kibana / changeme.

I got this:

and now it won't open again at all.

Hello dear,

Kindly make sure you are installing the correct versions of ES and Kibana. Some versions don't work with others; I would suggest downloading the latest versions for each.

Also regarding your last message, going to localhost:9200 and seeing that means that ES is up and running. You may have closed your cluster, or Elasticsearch, and that is why you are unable to see that JSON anymore.

If you go to Elasticsearch's doc (on their website), you will be able to find clear and very straight forward steps to install both Kibana and ES. As far as I know, you do not need to use any other applications or even docker to get these two running together.

Also kindly note that if you were to install them both together, this means Kibana will be reading the data off of Elasticsearch, because that is the default settings for Kibana; it will be listening on port 9200.

As far as I know, you can't use Kibana with other indexers or search engines so simply. This also goes for embedding your Kibana dashboards/graphs. You will find within Kibana URLs to use in iframes, sure, but it wont be as reliable/customizable as you would image.

If I were you, before going into setting up Kibana and ES, I would first read the documentations on Elasticsearch's website. They are very, very, VERY helpful.

Good luck!

Thank you so much guys!

Kibana is up and running now!
I simply gave up with Windows and OS X, so I installed it on Ubuntu and followed the same steps.

It's working perfectly!

Thank you for the great support!

" - - [27/Mar/2017:23:15:38 -0400] 'POST /servlet/rcopia.servlet.EngineServlet HTTP/1.1' 200 1123 23 - 'Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)'"

how to write pattern for above gc log

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.