Using a newer version of the java client with an older ES


(nicolas.long) #1

We want to use the 0.90.11 Java client because it contains a bug fix, but
we're on ES 0.90.9. Do we need to update ES too or can we get away with
just updating the client in this case?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e14bac67-c374-4ac2-9289-ff7120dd851e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly) #2

Unfortunately yes you will need to upgrade and match your ES Java client
with the ES server version.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8232b381-5c6d-47ab-a7ef-0e8640275716%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Binh Ly) #3

You should be ok. Give it a try. :slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b2709e63-9c50-4903-84dc-bfdcda313059%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4