ElasticSearch and Oracle Java version 1.7 update 45


(Anand Ganapathy) #1

Hi,

I heard that there are stability issues with running Oracle Java 1.7 update
45 and 0.90 ES versions. Does anyone know the details of this issue ?

It would be useful if ES team could publish the recommended Oracle Java
version to use and the reasons behind it.

Thanks,
Anand.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKv%3DHU%2BiQs_y09LYSjGk1ahf4fknXY6-qz5Zhh8WK43c-C%2BGJQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Adrien Grand) #2

Hi,

Indeed Lucene suffers from bugs in Oracle's Java 1.7u40 and 1.7u45.
However, 1.7u25 should be safe. You can find information about these bugs
in Lucene's JIRA and mailing-list. For example, here is one that affects
Java 1.7u40: https://issues.apache.org/jira/browse/LUCENE-5212

--
Adrien Grand

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAL6Z4j6DpFhNkDAKQzSc5-e%3DktOcHKdWRSs6T86DLwb8N3ueAQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3