Verification failed for logstash-output-zabbix

I am trying to install logstash-output-zabbix plugin with below command.

$sudo ./plugin install logstash-output-zabbix

But it shows below error.
" Validating logstash-output-zabbix

"Unable to download data from - SocketError: initialize: name or service not known 
          ERROR: Installation aborted, verification failed for logstash-output-zabbix"

What am I missing?


The "name or service not known" error message indicates that it can't resolve in DNS. Can you fetch by other means (e.g. with curl)?


curl: (6) Couldn't resolve host ''

this is the error with curl

Seems you have a general DNS issue then. That hostname resolves fine here:

$ dig +short

Is there any way, so that I can download plugin on local machine and upload to server through sftp?
what will be the location to save plugin file in that case?

logstash paths are below:

You can download the gem file from and install it with the plugin command. See the instructions at

Thanks for your support.
However, It gives below error. It seems security policy is not allowing me to download.

Too many retries, aborting, caused by Bundler::HTTPError
ERROR: Installation Aborted, message: Could not fetch specs from

Any version of logstash packed with zabbix output plugin?


Does anyone have an idea how to resolve this problem with logstash-output-zabbix-2.0.0?

p.s.: Logstash-2.0.0

It probably means your Logstash server is having difficulty downloading something (perhaps even a dependency). "Could not fetch specs from ..." implies that this is not something within Logstash, but rather a network availability issue.

Is your Logstash server behind a proxy, or in a datacenter where servers have limited ability to reach outbound servers (security)?

The zabbix output plugin is a community plugin. It is not bundled with Logstash.

I trying to install this plugin from local and have same issue :confused:

The zabbix output plugin has dependencies which will not be installed by merely installing the gem locally. As a result, it is trying to install the other dependencies and failing.

You could try to install the plugin to a directory on your desktop (or somewhere with complete internet access) and then copy the resultant files and/or dependencies to your locked-down Logstash instance.


I am currently having a similar issue. Could you shed some light on how you went about resolving this issue? I tried Aaron's suggestion by copying the contents of dependencies to /opt/logstash/vendor/bundle/jruby/1.9/gems directory and then install the locally developed plugin but it didn't work.

Hi Vinod,
Your logstash server seems to be secured behind proxy. Better to get it install from sys-administrator who can bypass proxy. I did it so.

You could try:
sudo -i
sudo export http_proxy=http://<HTTP_proxy>:port
sudo export https_proxy=https://<HTTPS_proxy>:port
sudo ../bin/plugin install /path/to/logstash-output-zabbix-1.0.0.gem

It worked for me.

Sunil Chaudhari.

Hi Sunil,
Bypassing proxy works for me too. But this is not what we want. Our servers are running on a private network without access to internet. We just want to be able to install this locally developed logstash plugin to be installed without having to connect to internet. The command I use to do this is as follows:

/opt/logstash/bin/plugin install --no-verify --local

However our plugin has dependency on 2 other gems - cassandra-driver & ione. I am however downloading these gems from repository and bundling with the image. Installing these gems also go through successfully but logstash doesn't seem to look from gem local repo, instead it has its own local gems repo. I dont really know how to make logstash point to this local gem repo or atleast have these dependencies and plugin itself itself under logstash gems repo. Any help on this would be highly appreciated. Thanks

1 Like

We recently took the approach of creating an "all plugins" release, but only in gzipped tar and zip formats.

If you deploy this, the Zabbix plugin and all dependencies will come with it.

Thanks Vinod, --no-verify worked for me.