Verifying if all norms disabled


(Ben Dotte) #1

Hi,

We do not utilize scoring so I'm trying to disable norms and set
index_options to "docs" for all fields. Every search has a sort order, so I
understand that disables scoring anyway, but it sounds like those options
are still a good idea to reduce the size of the index? I've attempted to
apply a dynamic template from another post:

"dynamic_templates": [{
"template_strings_no_norms" : {
"mapping" : {
"type" : "string",
"omit_norms" : true,
"index_options" : "docs"
},
"match" : "*",
"match_mapping_type" : "string"
}
}]

The HQ plugin shows this template is applied in the REST Indices/Settings
area. However when I perform a search with no sort order I still see a
score getting generated and the size of my index has not decreased. Is
there any way to verify if norms are in fact being disabled on the fields?

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/84968da5-599b-4bf2-bb32-80461b95f0d8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Ben Dotte) #2

When I wrote this, I had no explicit mappings defined. Now as I am adding
explicit mappings to each field, I've noticed my indexes seem to be "losing
weight", without turning off norms for each one. Searches without a sort
order still return a real-ish score, but with the smaller index size, I
take it the dynamic template is working, just that it only works with
explicitly-mapped fields.

On Wednesday, June 25, 2014 11:05:36 AM UTC-5, Ben Dotte wrote:

Hi,

We do not utilize scoring so I'm trying to disable norms and set
index_options to "docs" for all fields. Every search has a sort order, so I
understand that disables scoring anyway, but it sounds like those options
are still a good idea to reduce the size of the index? I've attempted to
apply a dynamic template from another post:

"dynamic_templates": [{
"template_strings_no_norms" : {
"mapping" : {
"type" : "string",
"omit_norms" : true,
"index_options" : "docs"
},
"match" : "*",
"match_mapping_type" : "string"
}
}]

The HQ plugin shows this template is applied in the REST Indices/Settings
area. However when I perform a search with no sort order I still see a
score getting generated and the size of my index has not decreased. Is
there any way to verify if norms are in fact being disabled on the fields?

Thanks,
Ben

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/249729dd-2802-485a-a050-be8e4cf3cfdc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3