Version 6.4.2 does not start (java.lang.NoSuchFieldError: LOG_DEFAULT_LEVEL_SETTING)


#1

I filed an issue on Github yesterday but turns out this is an environmental thing and not a bug. I am currently in the process of upgrading all our environments from 6.2.0 to 6.4.2 and am currently unable to do so on my local machine. Any help in resolving this will be appreciated.

Elasticsearch version: 6.4.2

Plugins installed: None

JVM version: openjdk version "10.0.2" 2018-07-17

OS version: Fedora 28 (4.18.9-200.fc28.x86_64 #1 SMP Thu Sep 20 02:43:23 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux)

Description of the problem including expected versus actual behavior:
I upgraded from ElasticSearch version 6.2.0 to 6.4.2 using the RPM package. After the installation, when I tried restarting ES, it didn't work. Checking the system logs (via journalctl), I found the following exception:

Exception in thread "main" java.lang.NoSuchFieldError: LOG_DEFAULT_LEVEL_SETTING
        at org.elasticsearch.common.logging.LogConfigurator.configureLoggerLevels(LogConfigurator.java:180)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:165)
        at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:119)
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:294)
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136)
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:127)
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124)
        at org.elasticsearch.cli.Command.main(Command.java:90)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:93)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:86)

I've tried this with both the "OSS" and "basic" versions. The error also occurs if I attempt a clean installation.

Steps to reproduce:

  1. Download ElasticSearch 6.4.2 RPM (https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-6.4.2.rpm)
  2. Install the RPM: sudo dnf install elasticsearch-6.4.2.rpm
  3. Watch system logs (journalctl -f) while starting ES (sudo systemctl start elasticsearch), the stack trace given above is generated

Relevant section of logs given above.

Link to issue on GH: https://github.com/elastic/elasticsearch/issues/34303


(Daniel Mitterdorfer) #2

Hi,

this error is raised when a field is not found at runtime but was present while the sources have been compiled. This points to problems with your classpath and the reason might be that 6.2.0 was not cleanly removed from your system. Can you please remove all versions of Elasticsearch and check whether there are any leftover files on your filesystem?

Please check the docs for the relevant paths, specifically you should check that /usr/share/elasticsearch is gone after uninstalling it and remove it manually if it is still present. Specifically, do NOT remove your data directory, otherwise your data are gone.

After the cleanup you can attempt a new reinstallation.

Daniel


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.