Virtual memory usage of elasticsearch


(Gokul nath) #1

Hi,

when i see top command virtual memory usage for ElasticSearch is high. I
have allocated min 1G and max 2G heap size for it. How can i control the
virtual memory usage? I am getting OOM frequently on ElasticSearch log.

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
3721 elastics 20 0 87.4g 2.1g 119m S 66.2 14.3
29:45.90 java

Thanks
Gokul

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/4fbb3426-f8d3-4cee-a6d6-d0d8003fd8b9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

If you get OOM, you should take a look at RSS (resident set size) of the
process. The VIRT (virtual memory) can span GB or TB, it does not matter at
all.

Jörg

On Wed, Aug 20, 2014 at 9:36 AM, Gokul nath gokularjunan@gmail.com wrote:

Hi,

when i see top command virtual memory usage for ElasticSearch is high. I
have allocated min 1G and max 2G heap size for it. How can i control the
virtual memory usage? I am getting OOM frequently on ElasticSearch log.

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
3721 elastics 20 0 87.4g 2.1g 119m S 66.2 14.3
29:45.90 java

Thanks
Gokul

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4fbb3426-f8d3-4cee-a6d6-d0d8003fd8b9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4fbb3426-f8d3-4cee-a6d6-d0d8003fd8b9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoEMf_K1%3DV7Rsz0BTi9Tdzj7kQ3CM-FXHeFn1q4UKdt96g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Gokul nath) #3

Thanks Jorg. I will look into that.

On Wednesday, 20 August 2014 13:20:38 UTC+5:30, Jörg Prante wrote:

If you get OOM, you should take a look at RSS (resident set size) of the
process. The VIRT (virtual memory) can span GB or TB, it does not matter at
all.

Jörg

On Wed, Aug 20, 2014 at 9:36 AM, Gokul nath <gokula...@gmail.com
<javascript:>> wrote:

Hi,

when i see top command virtual memory usage for ElasticSearch is high. I
have allocated min 1G and max 2G heap size for it. How can i control the
virtual memory usage? I am getting OOM frequently on ElasticSearch log.

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
3721 elastics 20 0 87.4g 2.1g 119m S 66.2 14.3
29:45.90 java

Thanks
Gokul

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/4fbb3426-f8d3-4cee-a6d6-d0d8003fd8b9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/4fbb3426-f8d3-4cee-a6d6-d0d8003fd8b9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/341063ae-4a61-4ea9-a308-3d3005c8e019%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4