WARN message when trying to install on windows 10

Hi! I'm trying to install elasticsearch on windows and i've followed the guid on here: Install Elasticsearch with .zip on Windows | Elasticsearch Guide [8.6] | Elastic.

The issue is, when I try to configure Elasticsearch I keep getting this error multiple times, and it goes on indifenetely.

[2023-03-23T12:20:53,039][WARN ][o.e.x.s.t.n.SecurityNetty4HttpServerTransport] [DESKTOP-V23ASFJ] received plaintext http traffic on an https channel, closing connection Netty4HttpChannel{localAddress=/, remoteAddress=/}

Any ideas as to what might cause it or how I could fix it? Thank you!


I would expect to see that message when something like curl or a web browser tries to issue a request to Elasticsearch. Are you checking an Elasticsearch endpoint? If so, are you using a web browser or are you using curl? If so, the first thing I would check is whether I've used http:// instead of https:// in the URL.

Is anything else interacting with Elasticsearch yet?

Hi and thank you!

I did trye to check elasticsearch through the browser by going to http://localhost:9200 - when the elasticsearch exe is not running, I get the error 'Unable to connect'.

When running the elasticsearch exe the error changes to "The connection was reset". I was also running a jupyter notebook at the time calling on elasticsearch, but it is closed now.

i should note that when trying to run the line:

action.auto_create_index: .monitoring*,.watches,.triggered_watches,.watcher-history*,.ml*

from the documentation, I get the error: action.auto_create_index: .monitoring*,.watches,.triggered_watches,.watcher-history*,.ml* 'action.auto_create_index:' is not recognized as an internal or external command, operable program or batch file.

Could this also be a potential issue?

Update: so I have tried running the elasticsearch exe without any browser or anything else open and it seemed to be working fine, but it then stopped updating on the cmd so I tried checking it by going to https://localhost:9200/

Now I got different errors displayed:

The first thing is to use https://localhost:9200 to connect from the browser, which ought to prompt you for a username and password rather than reporting "the connection was reset." "https" uses a secure, encrypted connection between your browser and the Elasticsearch server that you are running, whereas "http" does not use any encryption, which is why the warning had to do with "plain text."

action.auto_create_index: .monitoring*,.watches,.triggered_watches,.watcher-history*,.ml* is meant to be a line in the configuration file rather than a command, but you likely don't need to put it in your config.

The unknown_ca issue may be a little trickier. I will see if I can find something to help you and report back.

As of now, the cmd has stoped at [INFO ][o.e.i.g.DatabaseNodeService] [DESKTOP-V23ASFJ] successfully loaded geoip database file [GeoLite2-City.mmdb] and there were no more updates

I've tried logging on the https://localhost:9200 to connect to it through the browser, but unsure what username and password I should provide - I have tried the combination of 'elastic' (username) and 'changeme' (password), but the authentification was terminated.

When Elasticsearch was first starting up, its logs should have output a password for the default user, as shown here. Example:

The generated password for the elastic built-in superuser is:

It may still be in your terminal if you scroll up.

Unfortunately I have shut down the terminal, and the password doesn't seem to show in the elasticsearch_server logs - is there any other way I could recuperate it?

You are supposed to be able to reset the password with:

bin/elasticsearch-reset-password.bat -u elastic

However, this hasn't been working on my machine, which seems like a bug that I need to look into.

Try using:

 bin\elasticsearch-setup-passwords.bat auto


 bin\elasticsearch-setup-passwords.bat interactive

The first one can auto-generate passwords, while the second one lets you pick your password. It may not work if you have already tried the reset-password script from the previous comment.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.