][WARN ][o.e.d.r.RestController ] Content type detection for rest requests is deprecated. Specify the content type using the [Content-Type] header


(suchand) #1

Hi ,
@Ivan @mrubin
I am using Elsticsearch 5.5.3 , 4 node cluster.

I am getting this below log from one Node and CPU usage in this node is always 100%.

][WARN ][o.e.d.r.RestController ] Content type detection for rest requests is deprecated. Specify the content type using the [Content-Type] header.

16gb is the heap memory set.

Can someone please help me to resolve this issue.

Cluster health status is also copying here for referance:
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 3,
"active_primary_shards" : 856,
"active_shards" : 1712,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0,
"delayed_unassigned_shards" : 0,
"number_of_pending_tasks" : 0,
"number_of_in_flight_fetch" : 0,
"task_max_waiting_in_queue_millis" : 0,
"active_shards_percent_as_number" : 100.0
}


(Mark Walkom) #2

See https://www.elastic.co/guide/en/elasticsearch/reference/6.2/common-options.html#_content_type_requirements

Please don't ping people like that unless they are involved in the topic.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.