Watcher trigger time has wrong working

Dear All

 My Watcher can be work & alerted. 
 but watcher trigger with daily has wrong working.
 how to check what wrong of state?

Example Config Watcher Schedule trigger

"trigger": {
      "schedule": {
          "daily": {
            "at": [
              {
                "hour": [
                  0,
                  1,
                  2,
                  3,
                  4
                ],
                "minute": [
                  0,
                  5,
                  10,
                  15,
                  20,
                  25,
                  30,
                  35,
                  40,
                  45,
                  50,
                  55
                ]
              }
            ]
          }
        }
      }

Result execution history

Hi.
As stated in the documentation: https://www.elastic.co/guide/en/x-pack/current/trigger-schedule.html

Schedule triggers define when the watch execution should start based on date and time. All times are specified in UTC time.

so 04:00 UTC + 07:00 timezone offset = 11:00, it is the expected way of working.

I'm afraid there is no easy way to overcome UTC "translations" when working with watcher.

1 Like

Hi Andres

Thank you for the Update.

Now I try to Set schedule time with UTC Time.
My Calculate UTC Time -7 to my settings

IT WORK <3
:+1: :+1:

Thankyou.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.