When access to enterprise search it automatically redirect to kibana


I installed enterprise search on premise. Then access to http://my_ip:3002 it redirect to kibana. My kibana installed another server. Is there any config i missed?

My enterprise-search.yml has below config.

  allow_es_settings_modification: true
  elasticsearch.host: http://my_ip:9200
  elasticsearch.username: elastic
  elasticsearch.password: mypass
 ent_search.external_url: http://my_ext_ip:3002
secret_management.encryption_keys:    [secret_key]

Also, my console error is:

   Redirected to http://my_ext_ip:3002/ws/search    
  Completed 401 Unauthorized in 31ms
  Redirected to http://localhost:5601/app/enterprise_search/workplace_search/p/authorize_search?

I just observed that firstly it redirect to http://my_ext_ip:3002/ws/search then again redirect to http://localhost:5601 . I've no idea why it redirect to /ws/search. But i still can not found a solution.

Hi @MaralErdene_Tumursuh

Looks like you need to configure your Kibana settings for Enterprise Search: Configuration | Elastic Enterprise Search documentation [8.4] | Elastic

You will also need to configure your Enterprise Search settings for Kibana: Enterprise Search settings in Kibana | Kibana Guide [8.4] | Elastic

Your confusion at the redirect to Kibana makes me think you may have just upgraded versions. In older versions, the UI for Enterprise Search was baked into the Enterprise Search Server. In modern versions, these management UIs have moved to Kibana, so you are automatically redirected there. Be sure to read any release notes when you upgrade versions, to avoid these sorts of surprises. :slight_smile:

1 Like

Hi @Sean_Story thank you for your answer. I got it.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.