Need help with enterprise search config

I have installed Elasticsearch, kibana, and enterprise. I followed the configuration instructions and I keep getting this error:

We can’t establish a connection to Enterprise Search at the host URL http://localhost:3002

(opens in a new tab or window) due to the following error: Bad Gateway

This is a local install on a dev RHEL 8.3 machine. this is the config in the enterprise-search.yml

allow_es_settings_modification: true

elasticsearch full cluster URL:

elasticsearch.host: https://127.0.0.1:9200

Elasticsearch credentials:

elasticsearch.username: elastic
elasticsearch.password: password

Elasticsearch custom HTTP headers to add to each request:

elasticsearch.headers:
X-My-Header: Contents of the header

Elasticsearch SSL settings:

SSL communication with Elasticsearch enabled or not.

elasticsearch.ssl.enabled: true

Path to client certificate file to use for client-side validation from Elasticsearch.

elasticsearch.ssl.certificate:

Path to the keystore that contains Certificate Authorities for Elasticsearch SSL certificate.

elasticsearch.ssl.certificate_authority: /etc/elasticsearch/certs/http_ca.crt

Path to the key file for the client certificate.

elasticsearch.ssl.key:

Passphrase for the above key file.

elasticsearch.ssl.key_passphrase:

true to verify SSL certificate from Elasticsearch, false otherwise.

elasticsearch.ssl.verify: true

---------------------------------- Kibana -----------------------------------

Define the URL at which Enterprise Search can reach Kibana.
Defaults to http://localhost:5601 for testing purposes.

kibana.host: http://localhost:5601

Define the exposed URL at which users can reach Kibana.
Defaults to the kibana.host setting value if not set.

kibana.external_url: http://localhost:5601

------------------------------- Hosting & Network ---------------------------

Define the exposed URL at which users will reach Enterprise Search.
Defaults to localhost:3002 for testing purposes.
Most cases will use one of:

ent_search.external_url: http://localhost:3002

Web application listen_host and listen_port.
Your application will run on this host and port.

  • ent_search.listen_host: Must be a valid IPv4 or IPv6 address.
  • ent_search.listen_port: Must be a valid port number (1-65535).

ent_search.listen_host: 127.0.0.1
ent_search.listen_port: 3002

Hi @elastic_user2 ,

I assume that you're going off of the manual here, so please correct me if I am wrong.

From your post, it's not quite clear which rows of the enterprise-search.yml are commented out, and which are not. So it's a bit difficult to understand what is going on. Usually, when the http://localhost:3002/ is unreachable, it means that the Enterprise Search application hasn't started correctly. Would you be able to provide the output from the bin/enterprise-search - step 7 from the manual?

It would also help if we could see only the uncommented lines from enterprise-search.yml.