When running Curator action.yml, getting error


(Aleksei Saiko) #1

Hi there!
Can you please help with the following -
When I'm running the following command -

curator action.yml

I receive the following error -

Traceback (most recent call last):
  File "/usr/local/bin/curator", line 11, in <module>
    sys.exit(cli())
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 764, in __call__
    return self.main(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 717, in main
    rv = self.invoke(ctx)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 956, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/lib/python2.7/dist-packages/click/core.py", line 555, in invoke
    return callback(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/curator/cli.py", line 213, in cli
    run(config, action_file, dry_run)
  File "/usr/local/lib/python2.7/dist-packages/curator/cli.py", line 117, in run
    action_config = get_yaml(action_file)
  File "/usr/local/lib/python2.7/dist-packages/curator/utils.py", line 56, in get_yaml
    'Unable to parse YAML file. Error: {0}'.format(e))
curator.exceptions.ConfigurationError: Unable to parse YAML file. Error: mapping values are not allowed here
  in "<string>", line 20, column 13:
          source: creation_date
                ^

My action file -

---
actions:
  1:
    action: snapshot
    description: >-
      Make backups of indices older then 2 days.
    options:
      repository: my_s3_repository
      name: backup-%Y.%m.%d
      ignore_unavailable: False
      include_global_state: True
      partial: False
      wait_for_completion: True
      skip_repo_fs_check: False
      timeout_override:
      continue_if_exception: False
      disable_action: False
    filters:
    — filtertype: age
      source: creation_date
      direction: older
      unit: days
      unit_count: 2
      exclude:
  2:
    action: delete_indices
    description: >-
      Delete indices older than 2 days (based on index name).
    options:
      ignore_empty_list: True
      timeout_override:
      continue_if_exception: False
      disable_action: False
    filters:
    — filtertype: pattern
      source: name
      direction: older
      timestring: ‘%Y.%m.%d’
      unit: days
      unit_count: 2

My conf file -

---

client:
  hosts: 127.0.0.1
  port: 9200
  timeout: 30
  master_only: False

logging:
  loglevel: INFO
  logfile: /var/log/curator/curator.log

curator --version

curator, version 5.5.4

Logs -

2018-11-11 16:03:32,385 DEBUG                curator.cli                    run:108  Client and logging options validated.
2018-11-11 16:03:32,386 DEBUG                curator.cli                    run:112  default_timeout = 300
2018-11-11 16:03:32,386 DEBUG                curator.cli                    run:116  action_file: /root/.curator/action.yml

Would be appreciated for any help!


(Aaron Mildenstein) #2

When I pasted your content, I discovered a non-typical dash for - filtertype: age. I saw an emdash (—) instead of a regular hyphen (-). That might be the cause.


(Aleksei Saiko) #3

O damn... you're right, it's working now.
Such a stupid mistake...

Thanks!


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.