Why export ES_HEAP_SIZE=2g or bin/elasticsearch bin/elasticsearch --network.host -Xmx2g -Xms2g not work

Hi body,
My es version is 2.3.3 and I want to upgrade es memory to 2g from default value(1g).

following the document I firstly export environment ES_HEAP_SIZE in user bash file and restarting es. but the heap keep displaying 1g as it previously was(see the below graph), then I append -Xmx2g -Xms2g after my startup command "bin/elasticsearch bin/elasticsearch --network.host -Xmx2g -Xms2g" , but still the heap keep as the old(see the below graph).

Could somebody tell me why and how to set heap size?
Thanks a lot in advance

In the output of ps -fC java on the server running Elasticsearch, what are the values for the -Xms and -Xmx options? Do you see ES_HEAP_SIZE in the list of enviornment variables when you run cat /proc/<PID>/environment | tr \\0 \\n (where <PID> is the process ID of the Elasticsearch process)? Is there any warnings or errors printed when you start Elasticsearch?

Hi Joshua_Rich, the command env returns includes ES_HEAP_SIZE=2g. but cat /proc/PID/environ | tr \0 \n doesn't. I've export in /etc/profile file(see below), so why ES_HEAP_SIZE is not object to the PID and how to set?

issue solved, the cause is restart supervisord is necessary when es is started via supervisord.

Thanks Joshua_Rich