Why not auto release the memory


(David shi) #1

I use the _bulk interfaces concurrent writes 10M stress test, but after
the memory footprint has been stubbornly high, unless I restart the
elasticsearch.

How to make JVM automatically frees memory.

bigdesk screenshot

https://lh3.googleusercontent.com/-mdCKBVgQwTk/Ux_LRAs_zVI/AAAAAAAAAT4/xHMZHC4lCqo/s1600/Bigdesk.png

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e0837fa0-84f3-41ff-95e7-ea4fd55d5904%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Otis Gospodnetić) #2

Hi,

Are you seeing OOMs? Or long GC pauses? If not, don't worry - let the JVM
make use of the memory you let it use with -Xmx.

Conceptually similar to http://www.linuxatemyram.com/

Otis

Performance Monitoring * Log Analytics * Search Analytics
Solr & Elasticsearch Support * http://sematext.com/

On Tuesday, March 11, 2014 10:54:07 PM UTC-4, David shi wrote:

I use the _bulk interfaces concurrent writes 10M stress test, but after
the memory footprint has been stubbornly high, unless I restart the
elasticsearch.

How to make JVM automatically frees memory.

bigdesk screenshot

https://lh3.googleusercontent.com/-mdCKBVgQwTk/Ux_LRAs_zVI/AAAAAAAAAT4/xHMZHC4lCqo/s1600/Bigdesk.png

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ac1621bd-1f17-4f1e-96bf-3572408ad393%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(george_monroe) #3

Looks normal, especially under concurrent stress. You could try turning off
or stretching the refresh rate while you're indexing in concurrent bulks.
But let the JVM do it's job.

On Tuesday, March 11, 2014 7:54:07 PM UTC-7, David shi wrote:

I use the _bulk interfaces concurrent writes 10M stress test, but after
the memory footprint has been stubbornly high, unless I restart the
elasticsearch.

How to make JVM automatically frees memory.

bigdesk screenshot

https://lh3.googleusercontent.com/-mdCKBVgQwTk/Ux_LRAs_zVI/AAAAAAAAAT4/xHMZHC4lCqo/s1600/Bigdesk.png

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1b596a44-6f99-4d77-8426-c3dbdc743cbc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #4

There is more than enough free memory on the heap. Why are you bothering?

Jörg

On Wed, Mar 12, 2014 at 3:54 AM, David shi fackweb@gmail.com wrote:

I use the _bulk interfaces concurrent writes 10M stress test, but after
the memory footprint has been stubbornly high, unless I restart the
elasticsearch.

How to make JVM automatically frees memory.

bigdesk screenshot

https://lh3.googleusercontent.com/-mdCKBVgQwTk/Ux_LRAs_zVI/AAAAAAAAAT4/xHMZHC4lCqo/s1600/Bigdesk.png

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/e0837fa0-84f3-41ff-95e7-ea4fd55d5904%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/e0837fa0-84f3-41ff-95e7-ea4fd55d5904%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFuqNnc5efXyh-445%3DraZ8Orb2rVCGQQGc%3DqnaEAhcvKA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5