Windows logstash setting issue!

I have tried this code. my template is creating properly but index are not generating from the file. this is logstash.conf file. i am guessing it is 'sincedb' issue but I am confused. OS : windows 10, ELK version : 6.5.4

input {
 file {
    path => "C:\elk\logstash-6.5.4\logstash-6.5.4\config\review_data.json"
    start_position => "beginning"
    sincedb_path => "null"
    codec => "json"

output {
  stdout { codec => rubydebug }
  elasticsearch {
      hosts => ["http://localhost:9200/"] 
      index => "location_test"          
      template =>"C:\elk\logstash-6.5.4\logstash-6.5.4\config\template.json"
      template_overwrite => true

On Windows, use forward-slash in the path option for the file input, and the sincedb_path should be "NUL", not "null".

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.