With latest kibana git version problems with "map" panel


(Stefan Sabolowitsch) #1

Hi all,
i have here kibana3 with latest git version.
Tthis version no country show with this panel, but a query to elasticsearch
give my the correct values return.

Any idea ?
thx

Stefan

#-#-#-#-#-

[root@logger logstash]# curl -XGET
'http://192.168.1.95:9200/_all/_search?pretty' -d '{

"facets": {

"map": {
  "terms": {
    "field": "geoip.coordinates",
    "size": 100,
    "exclude": []
  },
  "facet_filter": {
    "fquery": {
      "query": {
        "filtered": {
          "query": {
            "bool": {
              "should": [
                {
                  "query_string": {
                    "query": "Trojan"
                  }
                },
                {
                  "query_string": {
                    "query": "scan"
                  }
                },
                {
                  "query_string": {
                    "query": "rbn"
                  }
                },
                {
                  "query_string": {
                    "query": "malware"
                  }
                },
                {
                  "query_string": {
                    "query": "web_server"
                  }
                },
                {
                  "query_string": {
                    "query": "dshield"
                  }
                },
                {
                  "query_string": {
                    "query": "cins"
                  }
                }
              ]
            }
          },
          "filter": {
            "bool": {
              "must": [
                {
                  "range": {
                    "@timestamp": {
                      "from": 1386075012171,
                      "to": "now"
                    }
                  }
                },
                {
                  "fquery": {
                    "query": {
                      "field": {
                        "syslog_program": {
                          "query": "\"snort\""
                        }
                      }
                    },
                    "_cache": true
                  }
                }
              ]
            }
          }
        }
      }
    }
  }
}

},

"size": 0

}'

{

"took" : 29,

"timed_out" : false,

"_shards" : {

"total" : 10,

"successful" : 10,

"failed" : 0

},

"hits" : {

"total" : 71197,

"max_score" : 1.0,

"hits" : [ ]

},

"facets" : {

"map" : {

  "_type" : "terms",

  "missing" : 0,

  "total" : 8,

  "other" : 0,

  "terms" : [ {

    "term" : "74.0132",

    "count" : 2

  }, {

    "term" : "47.61449999999999",

    "count" : 2

  }, {

    "term" : "40.708200000000005",

    "count" : 2

  }, {

    "term" : "122.348",

    "count" : 2

  } ]

}

}

}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9c4c7252-cd7a-4021-8855-c225d34791d4%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2