Workplace search is not displaying

Hi,
I am facing weird issue in enterprise search.
I setup Enterprise search on docker environment, it was showing to choose App search and Workplace search on home page. I created a role(example_role) and a user(example_mcuser) under it in kibana and Add Mapping in enterprise search for that user(I added that user as admin). from reference https://www.elastic.co/guide/en/workplace-search/current/workplace-search-security.html
I follow instructions, add mapping user in enterpris esearch but after that it is only showing app search option, workplace search option is not showing.
I login with superuser(enterprise_search) and custom created user(example_mcuser).
No changes.

A screenshot is below

Hi Vicram,

Since you created user in Kibana I'm going to assume you are using ent_search.auth.source=elasticsearch-native.

It's likely that you added a mapping in App Search application. Since the created mapping only gives example_mcuser access to App Search it is expected for this user to only see App Search on home page (they don't have a role mapping in Workplace Search and are not authorized to access it).

You should still be able to log in as elastic superuser who always has access to both apps. If you followed instructions for Linux/MacOS packages, you could obtain it on Step 4 here: Installing Workplace Search | Workplace Search Guide [7.10] | Elastic

There is also an option to reset all role mappings. See here: Installing Workplace Search | Workplace Search Guide [7.10] | Elastic

And another way to see Workplace Search again is to remove all custom role mappings from App Search. Once there are no custom role mappings, all users should become admins and get access to both applications.

Let me know if it helps!