X-Pack 5.0.0-beta1 exporters not started


(Martin Kaemmerling) #1

When starting Elasticsearch i got the following errors in the logfile:

[2016-10-11T10:41:54,759][WARN ][o.e.x.m.e.h.NodeFailureListener] connection failed to node at [http://..114.251:9200]
[2016-10-11T10:41:54,760][ERROR][o.e.x.m.e.h.VersionHttpResource] failed to verify minimum version [5.0.0-alpha6] on the [xpack.monitoring.exporters.id1] monitoring cluster
org.elasticsearch.client.ResponseException: GET http://..114.251:9200/?filter_path=version.number: HTTP/1.1 503 Service Unavailable
{
"version" : {
"number" : "5.0.0-beta1"
}
}

    at org.elasticsearch.client.RestClient$1.completed(RestClient.java:310) ~[?:?]
    at org.elasticsearch.client.RestClient$1.completed(RestClient.java:299) ~[?:?]
    at org.apache.http.concurrent.BasicFuture.completed(BasicFuture.java:119) ~[?:?]
    at org.apache.http.impl.nio.client.DefaultClientExchangeHandlerImpl.responseCompleted(DefaultClientExchangeHandlerImpl.java:177) ~[?:?]
    at org.apache.http.nio.protocol.HttpAsyncRequestExecutor.processResponse(HttpAsyncRequestExecutor.java:436) ~[?:?]
    at org.apache.http.nio.protocol.HttpAsyncRequestExecutor.inputReady(HttpAsyncRequestExecutor.java:326) ~[?:?]
    at org.apache.http.impl.nio.DefaultNHttpClientConnection.consumeInput(DefaultNHttpClientConnection.java:265) ~[?:?]
    at org.apache.http.impl.nio.client.InternalIODispatch.onInputReady(InternalIODispatch.java:81) ~[?:?]
    at org.apache.http.impl.nio.client.InternalIODispatch.onInputReady(InternalIODispatch.java:39) ~[?:?]
    at org.apache.http.impl.nio.reactor.AbstractIODispatch.inputReady(AbstractIODispatch.java:114) ~[?:?]
    at org.apache.http.impl.nio.reactor.BaseIOReactor.readable(BaseIOReactor.java:162) ~[?:?]
    at org.apache.http.impl.nio.reactor.AbstractIOReactor.processEvent(AbstractIOReactor.java:337) ~[?:?]
    at org.apache.http.impl.nio.reactor.AbstractIOReactor.processEvents(AbstractIOReactor.java:315) ~[?:?]
    at org.apache.http.impl.nio.reactor.AbstractIOReactor.execute(AbstractIOReactor.java:276) ~[?:?]
    at org.apache.http.impl.nio.reactor.BaseIOReactor.execute(BaseIOReactor.java:104) ~[?:?]
    at org.apache.http.impl.nio.reactor.AbstractMultiworkerIOReactor$Worker.run(AbstractMultiworkerIOReactor.java:588) ~[?:?]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_91]

[2016-10-11T10:41:54,766][INFO ][o.e.x.m.e.Exporters ] [by0kmh] skipping exporter [id1] as it isn't ready yet

Any ideas to repair/bypass this check?


(Martin Kaemmerling) #2

I fixed this by deleting the empty index .security


(CJ Cenizal) #3

Thanks for posting the solution to your problem!

CJ


(system) #4