X-pack AIX installation issue

Hello Elastic Team,

I know elastic is not completely supported in AIX. But I still am able to run different version of elastic (5.4.3 and 5.3.0) in AIX with out any issues.

Now to add security to elastic we need to add x-pack to AIX elastic. In windows we used offline package (5.4.3) and installed. Its working. But we are facing issues in AIX to install x-pack for elastic search.

We copied the elastic along with x-pack installation from windows and we tried to start the server and we got the following error

[2017-07-11T08:39:38,265][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: ElasticsearchException[Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]]; nested: InvocationTargetException; nested: IllegalArgumentException[none of the ciphers [TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256, TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256, TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA, TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA, TLS_RSA_WITH_AES_128_CBC_SHA256, TLS_RSA_WITH_AES_128_CBC_SHA] are supported by this JVM];


Caused by: org.elasticsearch.ElasticsearchException: Failed to load plugin class [org.elasticsearch.xpack.XPackPlugin]

We also tried to do online and offline installation using commands, but failed.
$ bin/elasticsearch-plugin install file://home/jprakash/ESwithX-packFromWindows/x-pack-5.4.3.zip
/usr/bin/ksh: bin/elasticsearch-plugin: cannot execute
$ bin/elasticsearch-plugin install x-pack
/usr/bin/ksh: bin/elasticsearch-plugin: cannot execute

Can you please help me here ?


Elasticsearch and X-Pack are not at all supported on AIX, nor on any IBM JVM.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.