X-pack on es 6.1.0 and configsync not working


(Zenia) #1

Plugin is installed, but cant start

[2018-02-19T22:43:19,697][ERROR][o.c.e.c.s.ConfigSyncService] [node01] Failed to start ConfigFileUpdater.
org.elasticsearch.ElasticsearchSecurityException: action [indices:admin/exists] is unauthorized for user _[system]

[transport] [access_denied] origin_type=[local_node], origin_address=[172.17.0.2], principal=[_system], action=[indices:admin/exists], indices=[.configsync], request=[IndicesExistsRequest]


(Tim Vernum) #2

It doesn't look like the config sync plugin is compatible with X-Pack security.
I would suggest that you raise the issue with the config sync authors.


(Zenia) #3

Is there a way to give _system access to .configsync indice ?


(Tim Vernum) #4

No, that is not possible.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.