X-pack scheduling email attachment issue


(uday kiran) #1

Hi,

I am using x-pack alpha version. iam able to send mails but when I am trying to schedule the pdf report attachment to email. I am getting following error

[2016-04-29 12:26:17,404][ERROR][watcher.actions.email.service.attachment] Error executing HTTP request: [host[192.168.4.127], port[5601], method[GET], path[//app/reporting/visualization/Sample_report]: [sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target]
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

my watcher action config as follows,

"actions": {
"send_email": {
"email": {
"to": ["client@xxx.com", "client@xxx.com"],
"subject": "Cluster Status",
"body": "Cluster status is YELLOW",
"attachments" : {
"Sample_report.pdf" : {
"http" : {
"content_type" : "application/pdf",
"request" : {
"url": "https://localhost:5601//app/reporting/visualization/Sample_report?_g=(refreshInterval:(display:'5%20seconds',pause:!f,section:1,value:5000),time:(from:now%2Fd,mode:quick,to:now%2Fd))&_a=(filters:!(),linked:!f,query:(query_string:(analyze_wildcard:!t,query:'*')),uiState:(),vis:(aggs:!((id:'1',params:(),schema:metric,type:count),(id:'2',params:(customInterval:'2h',extended_bounds:(),field:trigger_event.triggered_time,interval:auto,min_doc_count:1),schema:bucket,type:date_histogram),(id:'3',params:(field:result.actions.status,order:desc,orderBy:'1',size:5),schema:bucket,type:terms)),listeners:(),params:(perPage:10,showMeticsAtAllLevels:!f,showPartialRows:!f),title:Sample_report,type:table))"
}
}
},
"data.yml" : {
"data" : {
"format" : "yaml"
}
}
}
}
}
}

my config in elasticsearch.yml is as follows,

watcher.actions.email.service.account:
outlook_account:
profile: outlook
email_defaults:
from: 'xxxxx>'
smtp:
auth: true
starttls.enable: true
host: smtp.xxx.com
port: 000
user: xxxx@xxx.com
password: xxx
ssl.trust: smtp.xxx.com

Please help me to resolve this.

Thanks,
Uday.K


(system) #2