X509: cannot validate certificate for because it doesn't contain any IP SANs

I'm just start 7.1 ES & KB & Metricbeat
I have an error

my metricbeat.yml

#============================== Kibana =====================================

  host: ""
#-------------------------- Elasticsearch output ------------------------------
  hosts: [""]

  # Optional protocol and basic auth credentials.
  protocol: "https"
  username: "elastic"
  password: "d8Z46pgoFEd1rQNdOfDX"

my elasticsearch.yml

# ---------------------------------- Network -----------------------------------
# Set the bind address to a specific IP (IPv4 or IPv6):
http.host: ""
# Set a custom port for HTTP:
http.port: 9200
# For more information, consult the network module documentation.
# --------------------------------- Discovery ----------------------------------
# Pass an initial list of hosts to perform discovery when this node is started:
# The default list of hosts is ["", "[::1]"]
discovery.seed_hosts: [""]
# Bootstrap the cluster using an initial set of master-eligible nodes:
cluster.initial_master_nodes: ["node-1"]

xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: elastic-certificates.p12
xpack.security.transport.ssl.keystore.password: "password"
xpack.security.transport.ssl.truststore.path: elastic-certificates.p12
xpack.security.transport.ssl.truststore.password: "password"

xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: elastic-certificates.p12
xpack.security.http.ssl.keystore.password: "password"
xpack.security.http.ssl.truststore.path: elastic-certificates.p12
xpack.security.http.ssl.truststore.password: "password"

my kibana.yml

server.port: 5601
server.host: ""

elasticsearch.hosts: [""]

elasticsearch.username: "kibana"
elasticsearch.password: "Y3B2c5U0izQF2Who2qyj"

server.ssl.enabled: true
server.ssl.certificate: /etc/kibana/instance/instance.crt
server.ssl.key: /etc/kibana/instance/instance.key

elasticsearch.ssl.certificateAuthorities: ["/etc/kibana/elastic-ca.pem"]

elasticsearch.ssl.verificationMode: none

how can i find problem??
to config IP SANs
is it need set something??
please help me

I think the issue is with your certificate. When generating the certificate you must ensure it contains the IP address above. If you google for the above error without the IP address inside you will find a few ways on how to do it. To avoid the complexity of adding IP addresses, perhaps just use domain names and a DNS?

Hi, Thanks for reply
i solve this problem using this site

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.