Yarn start not working


(Alex) #1

Hi,

Just yesterday yarn start was working perfectly when I needed to set up a development server from the master branch. Today for some reason it keeps failing with
failed to watch files! Error: watch /home/user/kibana/src/core_plugins/kibana/common/tutorials/tutorial_category.js ENOSPC

I have tried deleting the kibana folder, recloning, and following the steps in the setting up the development environment guide but it keeps failing.


(Alex) #2

I am on Centos by the way


(kulkarni) #3

"ENOSPC" means that there is no space on the drive, so where do you save your file? Might be a disk issue. I think its not related to yarn at all. I also found some one else reported this error : https://github.com/facebook/jest/issues/3254

See if that helps !

Good luck
Rashmi


(Alex) #4

Thanks so much!

To anyone else wondering,

echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p
seems to be the solution and worked for me. Too many files are being watched, this command reduces the amount that are watched for large projects.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.