Yum install on Centos7 gives no broken service for systemd


#1

When I install Elasticsearch 5.1.2 on a Centos7 with help of Puppet/Puppet-forge is see this:

ls -al /etc/systemd/system/elasticsearch.service
lrwxrwxrwx 1 root root 9 Feb 3 15:09 /etc/systemd/system/elasticsearch.service -> /dev/null

Also I have no elasticsearch.yml files in /etc/elasticsearch/, only jvm*.

I have tried and do a "pure" yum install and still get that the systemd service for elasticsearch goes towards /dev/null. Both Kibana and Logstash didn't have this problem.

My logs from YUM do not give any hints and Elasticsearch creates no logs.
Anyone got any tricks for me to try?


#2

I have now seen this with help from a co-worker:

systemctl status elasticsearch.service
‚óŹ elasticsearch.service
Loaded: masked (/dev/null; bad)

Why does it mask it and what have I missed in my profile?


(Tyler Langlois) #3

Hi @m0n0lith,

The Puppet module works by managing instances of Elasticsearch. This is done primarily because many people need the ability to run more than one instance of Elasticsearch on a host.

The documentation explains how to define a running instance of elasticsearch, but in the simplest form:

elasticsearch::instance { 'master' : }

Will create and manage one instance of Elasticsearch on your host.

systemctl status elasticsearch-master

(or whatever you choose to name your instance). Does that answer your question?


#4

Tanks! that help me a lot.
I thought that the name was just for cluster setup and so on.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.