Zen Discovery, Stop Words and Synonyms Problem

hi

I am using ElasticSearch Zen discovery, however I am having trouble in
using custom stopword and synonyms. "first server" contains the files put
in the second that has the files on the disk.

[error]

RemoteTransportException [[Punisher] [inet [/ 177.67.118.98:9300]] [indices
/ create]]; nested: IndexCreationException [[108099] failed to create
index]; nested: FailedToResolveConfigException [Failed to resolve path
config [/ var / www / html / elasticsearch_api / current / config /
stopwords.txt] tried file path [/ var / www / html / elasticsearch_api /
current / config / stopwords.txt], path file [/ usr / local / share /
ElasticSearch / config / var / www / html / elasticsearch_api / current /
config / stopwords.txt], and classpath];

Server 1 - Setup

discovery.zen.ping.timeout: 3s
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["192.168.1.102:9200"]

Server 2 - setup default.

There Any solution?

--

Hi,

Not sure what you mean by your first paragraph. The stopwords.txt file
needs to exist on every node in the cluster. The file will not be
distributed automatically if it is located only on one server.

If the file does exist, perhaps the issue is permissions. Where exactly in
the filesystem is the file located?

Cheers,

Ivan

On Thu, Nov 22, 2012 at 8:04 AM, Honjoya jhonjoya@tray.net.br wrote:

hi

I am using ElasticSearch Zen discovery, however I am having trouble in
using custom stopword and synonyms. "first server" contains the files put
in the second that has the files on the disk.

[error]

RemoteTransportException [[Punisher] [inet [/ 177.67.118.98:9300]]
[indices / create]]; nested: IndexCreationException [[108099] failed to
create index]; nested: FailedToResolveConfigException [Failed to resolve
path config [/ var / www / html / elasticsearch_api / current / config /
stopwords.txt] tried file path [/ var / www / html / elasticsearch_api /
current / config / stopwords.txt], path file [/ usr / local / share /
ElasticSearch / config / var / www / html / elasticsearch_api / current /
config / stopwords.txt], and classpath];

Server 1 - Setup

discovery.zen.ping.timeout: 3s
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["192.168.1.102:9200"]

Server 2 - setup default.

There Any solution?

--

--

Thanks ...

I stopped the second server .The indexing in the first server running
normally.
When I try to create the index with the second server started - I have
this problem . The server 1 and server 2 are on different machines.

Only the first server containing the file stopword.txt in
/usr/local/share/ElasticSearch/conf/stopword.txt . The ElasticSearch can
not replicate it to the second server?

need to replicate it manually?

Em quinta-feira, 22 de novembro de 2012 14h47min23s UTC-2, Ivan Brusic
escreveu:

Hi,

Not sure what you mean by your first paragraph. The stopwords.txt file
needs to exist on every node in the cluster. The file will not be
distributed automatically if it is located only on one server.

If the file does exist, perhaps the issue is permissions. Where exactly in
the filesystem is the file located?

Cheers,

Ivan

On Thu, Nov 22, 2012 at 8:04 AM, Honjoya <jhon...@tray.net.br<javascript:>

wrote:

hi

I am using ElasticSearch Zen discovery, however I am having trouble in
using custom stopword and synonyms. "first server" contains the files put
in the second that has the files on the disk.

[error]

RemoteTransportException [[Punisher] [inet [/ 177.67.118.98:9300]]
[indices / create]]; nested: IndexCreationException [[108099] failed to
create index]; nested: FailedToResolveConfigException [Failed to resolve
path config [/ var / www / html / elasticsearch_api / current / config /
stopwords.txt] tried file path [/ var / www / html / elasticsearch_api /
current / config / stopwords.txt], path file [/ usr / local / share /
ElasticSearch / config / var / www / html / elasticsearch_api / current /
config / stopwords.txt], and classpath];

Server 1 - Setup

discovery.zen.ping.timeout: 3s
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["192.168.1.102:9200"]

Server 2 - setup default.

There Any solution?

--

--

Yes, the file needs to be replicated manually.

On Thu, Nov 22, 2012 at 9:01 AM, Honjoya jhonjoya@tray.net.br wrote:

Thanks ...

I stopped the second server .The indexing in the first server running
normally.
When I try to create the index with the second server started - I have
this problem . The server 1 and server 2 are on different machines.

Only the first server containing the file stopword.txt in
/usr/local/share/ElasticSearch/conf/stopword.txt . The ElasticSearch can
not replicate it to the second server?

need to replicate it manually?

Em quinta-feira, 22 de novembro de 2012 14h47min23s UTC-2, Ivan Brusic
escreveu:

Hi,

Not sure what you mean by your first paragraph. The stopwords.txt file
needs to exist on every node in the cluster. The file will not be
distributed automatically if it is located only on one server.

If the file does exist, perhaps the issue is permissions. Where exactly
in the filesystem is the file located?

Cheers,

Ivan

On Thu, Nov 22, 2012 at 8:04 AM, Honjoya jhon...@tray.net.br wrote:

hi

I am using ElasticSearch Zen discovery, however I am having trouble in
using custom stopword and synonyms. "first server" contains the files put
in the second that has the files on the disk.

[error]

RemoteTransportException [[Punisher] [inet [/ 177.67.118.98:9300]]
[indices / create]]; nested: IndexCreationException [[108099] failed to
create index]; nested: FailedToResolveConfigException [Failed to resolve
path config [/ var / www / html / elasticsearch_api / current / config /
stopwords.txt] tried file path [/ var / www / html / elasticsearch_api /
current / config / stopwords.txt], path file [/ usr / local / share /
ElasticSearch / config / var / www / html / elasticsearch_api / current /
config / stopwords.txt], and classpath];

Server 1 - Setup

discovery.zen.ping.timeout: 3s
discovery.zen.ping.multicast.**enabled: false
discovery.zen.ping.unicast.**hosts: ["192.168.1.102:9200"]

Server 2 - setup default.

There Any solution?

--

--

--

Thanks...

Em quinta-feira, 22 de novembro de 2012 15h04min32s UTC-2, Ivan Brusic
escreveu:

Yes, the file needs to be replicated manually.

On Thu, Nov 22, 2012 at 9:01 AM, Honjoya <jhon...@tray.net.br<javascript:>

wrote:

Thanks ...

I stopped the second server .The indexing in the first server running
normally.
When I try to create the index with the second server started - I have
this problem . The server 1 and server 2 are on different machines.

Only the first server containing the file stopword.txt in
/usr/local/share/ElasticSearch/conf/stopword.txt . The ElasticSearch can
not replicate it to the second server?

need to replicate it manually?

Em quinta-feira, 22 de novembro de 2012 14h47min23s UTC-2, Ivan Brusic
escreveu:

Hi,

Not sure what you mean by your first paragraph. The stopwords.txt file
needs to exist on every node in the cluster. The file will not be
distributed automatically if it is located only on one server.

If the file does exist, perhaps the issue is permissions. Where exactly
in the filesystem is the file located?

Cheers,

Ivan

On Thu, Nov 22, 2012 at 8:04 AM, Honjoya jhon...@tray.net.br wrote:

hi

I am using ElasticSearch Zen discovery, however I am having trouble in
using custom stopword and synonyms. "first server" contains the files put
in the second that has the files on the disk.

[error]

RemoteTransportException [[Punisher] [inet [/ 177.67.118.98:9300]]
[indices / create]]; nested: IndexCreationException [[108099] failed to
create index]; nested: FailedToResolveConfigException [Failed to resolve
path config [/ var / www / html / elasticsearch_api / current / config /
stopwords.txt] tried file path [/ var / www / html / elasticsearch_api /
current / config / stopwords.txt], path file [/ usr / local / share /
ElasticSearch / config / var / www / html / elasticsearch_api / current /
config / stopwords.txt], and classpath];

Server 1 - Setup

discovery.zen.ping.timeout: 3s
discovery.zen.ping.multicast.**enabled: false
discovery.zen.ping.unicast.**hosts: ["192.168.1.102:9200"]

Server 2 - setup default.

There Any solution?

--

--

--