Zen unicast discovery -- pulling hair out :-(


(jessejlt) #1

I'm having a difficult time getting two nodes to communicate with each
other using Zen unicast discovery. I've setup a gist at
https://gist.github.com/2695724 that describes the issue, shows the
logs, and lists the two machines' configs. Any help is appreciated.
Thanks!


(David Pilato) #2

Not sure but you should add your slave and your master in both nodes config files.
discovery.zen.ping.unicast.hosts: ["153.32.228.250:9300","theothernode:9300"]
HTH
David

Le 14 mai 2012 à 21:04, jessejlt jessejlt@gmail.com a écrit :

I'm having a difficult time getting two nodes to communicate with each
other using Zen unicast discovery. I've setup a gist at
https://gist.github.com/2695724 that describes the issue, shows the
logs, and lists the two machines' configs. Any help is appreciated.
Thanks!


(Mohit Chawla) #3

discovery.zen.ping.unicast.hosts should've both hosts in both the
config files, I guess.

On Tue, May 15, 2012 at 12:34 AM, jessejlt jessejlt@gmail.com wrote:

I'm having a difficult time getting two nodes to communicate with each
other using Zen unicast discovery. I've setup a gist at
https://gist.github.com/2695724 that describes the issue, shows the
logs, and lists the two machines' configs. Any help is appreciated.
Thanks!


(Shay Banon) #4

Can you post the full log of both the first node in the cluster, and the
new node that you are brining up?

On Mon, May 14, 2012 at 10:04 PM, jessejlt jessejlt@gmail.com wrote:

I'm having a difficult time getting two nodes to communicate with each
other using Zen unicast discovery. I've setup a gist at
https://gist.github.com/2695724 that describes the issue, shows the
logs, and lists the two machines' configs. Any help is appreciated.
Thanks!


(jessejlt) #5

I've updated the discovery hosts to include both the primary and new
node: https://gist.github.com/2695724#file_master.yml
I turned on discovery trace logging and posted the logs for both nodes
at: https://gist.github.com/2695724#gistcomment-342383

Thanks!
-jesse

On May 15, 1:52 pm, Shay Banon kim...@gmail.com wrote:

Can you post the full log of both the first node in the cluster, and the
new node that you are brining up?

On Mon, May 14, 2012 at 10:04 PM, jessejlt jesse...@gmail.com wrote:

I'm having a difficult time getting two nodes to communicate with each
other using Zen unicast discovery. I've setup a gist at
https://gist.github.com/2695724that describes the issue, shows the
logs, and lists the two machines' configs. Any help is appreciated.
Thanks!


(jagdeep) #6

I have similar master slave configuration and it works well for me. I
have given IP addresses in both ymls, so configuration wise i dont see
any issue. Can you try to increase ping time out.. in case any network
latency is there..

Regards
Jagdeep

On Jun 5, 1:55 am, jessejlt jesse...@gmail.com wrote:

I've updated the discovery hosts to include both the primary and new
node:https://gist.github.com/2695724#file_master.yml
I turned on discovery trace logging and posted the logs for both nodes
at:https://gist.github.com/2695724#gistcomment-342383

Thanks!
-jesse

On May 15, 1:52 pm, Shay Banon kim...@gmail.com wrote:

Can you post the full log of both the first node in the cluster, and the
new node that you are brining up?

On Mon, May 14, 2012 at 10:04 PM, jessejlt jesse...@gmail.com wrote:

I'm having a difficult time getting two nodes to communicate with each
other using Zen unicast discovery. I've setup a gist at
https://gist.github.com/2695724thatdescribes the issue, shows the
logs, and lists the two machines' configs. Any help is appreciated.
Thanks!


(Igor Motov) #7

Jesse,

You are running elasticsearch version 0.18.7 on master and version 0.19.3
on media-slave. You cannot combine nodes with different elasticsearch
versions into a single cluster.

Igor

On Tuesday, June 5, 2012 1:14:40 AM UTC-4, jagdeep wrote:

I have similar master slave configuration and it works well for me. I
have given IP addresses in both ymls, so configuration wise i dont see
any issue. Can you try to increase ping time out.. in case any network
latency is there..

Regards
Jagdeep

On Jun 5, 1:55 am, jessejlt jesse...@gmail.com wrote:

I've updated the discovery hosts to include both the primary and new
node:https://gist.github.com/2695724#file_master.yml
I turned on discovery trace logging and posted the logs for both nodes
at:https://gist.github.com/2695724#gistcomment-342383

Thanks!
-jesse

On May 15, 1:52 pm, Shay Banon kim...@gmail.com wrote:

Can you post the full log of both the first node in the cluster, and
the

new node that you are brining up?

On Mon, May 14, 2012 at 10:04 PM, jessejlt jesse...@gmail.com
wrote:

I'm having a difficult time getting two nodes to communicate with
each

other using Zen unicast discovery. I've setup a gist at
https://gist.github.com/2695724thatdescribes the issue, shows the
logs, and lists the two machines' configs. Any help is appreciated.
Thanks!


(Shay Banon) #8

It seems like what you call the slave node (bad naming by the way, there
isn't really a slave in elasticsearch cluster model) send ping requests but
receives no responses, so it elects itself as master. Can set discovery
logging to TRACE? I am missing some logging elements where it shows which
addresses it tries to ping. Also, can you remove the [9300-9400] part, and
just use host? It will use the proper port number automatically.

On Mon, Jun 4, 2012 at 10:55 PM, jessejlt jessejlt@gmail.com wrote:

I've updated the discovery hosts to include both the primary and new
node: https://gist.github.com/2695724#file_master.yml
I turned on discovery trace logging and posted the logs for both nodes
at: https://gist.github.com/2695724#gistcomment-342383

Thanks!
-jesse

On May 15, 1:52 pm, Shay Banon kim...@gmail.com wrote:

Can you post the full log of both the first node in the cluster, and the
new node that you are brining up?

On Mon, May 14, 2012 at 10:04 PM, jessejlt jesse...@gmail.com wrote:

I'm having a difficult time getting two nodes to communicate with each
other using Zen unicast discovery. I've setup a gist at
https://gist.github.com/2695724that describes the issue, shows the
logs, and lists the two machines' configs. Any help is appreciated.
Thanks!


(AndreyTonteey13) #9

I am also interested in the hair wigs and as I like to change my look sometimes with a new hair style, but having the hair cut is really a trouble, but each time I just buy cheap hair wigs online and told the seller the style I want and then soon I can find the one satify me. So I have never met the problem as you. Not long ago I get a BOB Hairstyles For Sale for myself and it bring me a new style as before.


(BulahLerry) #10

Hair extensions and hairpieces really can help to improve the looking of people and help to change them a lot hair extensions and hairpieces if choosing the right type and right style of hair wigs for you, of course that you will look and become more and more attractive and also buy cheap hair wigs now is easy as you can just get the ideal style that you want online at online shops now. I have just buy me a white wigs and it is perfect.


(system) #11