5.2 Offline Plugin Install


#1

Hi,

I'm trying to use the new offline plugin install feature and it doesn't seem to work... looks like I'm missing something.
I created a custom plugin that pushes events to google pub sub.

Steps:

  1. Installed the plugin on a staging server (with internet access) and checked that its working.

  2. packed the plugin with command:
    bin/logstash-plugin prepare-offline-pack logstash-output-google-cloud-pubsub

That generated the compressed file: logstash-offline-plugins-5.2.0.zip

  1. I copied the file to the remote server to logstash-5.2.0 installation directory and executed command:
    bin/logstash-plugin install file:///home/bi/logstash-5.2.0/logstash-offline-plugins-5.2.0.zip

got this error:
ERROR: File not found for: file:///home/bi/logstash-5.2.0/logstash-offline-plugins-5.2.0.zip, message: Can't file local file /home/bi/logstash-5.2.0/logstash-offline-plugins-5.2.0.zip

  1. It looks like it doesn't like the "file://" part so i tried this:
    bin/logstash-plugin install /home/bi/logstash-5.2.0/logstash-offline-plugins-5.2.0.zip

got this error:
Validating /home/bi/logstash-5.2.0/logstash-offline-plugins-5.2.0.zip
Unable to download data from https://rubygems.org - Errno::ECONNREFUSED: Connection refused - Connection refused (https://api.rubygems.org/latest_specs.4.8.gz)

  1. Tried to install with --no-verify:
    bin/logstash-plugin install --no-verify /home/bi/logstash-5.2.0/logstash-offline-plugins-5.2.0.zip

got this error:
Installing /home/bi/logstash-5.2.0/logstash-offline-plugins-5.2.0.zip
Plugin not found, aborting
ERROR: Installation Aborted, message: Could not find gem '/home/bi/logstash-5.2.0/logstash-offline-plugins-5.2.0.zip (>= 0) java' in any of the gem sources listed in your Gemfile or installed on this machine.

Any idea what is the issue here?
Thanks


#2

never mine, stupid mistake - path wasn't correct.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.