[7.4.1] Problem histogram "unable to retrieve max and min values..."

Hi there,

I'm having some problems creating a histogram in Kibana 7.4.1.

It is very simple, splitting the X-axis over a long field totalLatency.

The "error" returned is Unable to retrieve max and min values to auto-scale histogram buckets. This may lead to poor visualization performance.

It never occurred in past versions of Kibana (e.g. 6.3.0).

I even tried flagging the expand bounds and setting the min a max values or changing the value in the Minimum interval field, but it keeps returning the same error.

It takes ages to load (even on small amount of data) and eventually shows the visualization (as you can see from the above posted image) and the error.

The real problem is in the dashboard, where it prevents the other visualizations from loading properly.

Any ideas? Might it be a possible bug of 7.4.1 histograms?


How many indices/documents does your Kibana index-pattern cover? The histogram is doing a min and max aggregation, https://github.com/elastic/kibana/blob/master/src/legacy/ui/public/agg_types/buckets/histogram.ts#L102, to retrieve the min and max values and it looks like that request may be timing out.

Would you mind putting a break point at https://github.com/elastic/kibana/blob/master/src/legacy/ui/public/agg_types/buckets/histogram.ts#L123 and returning the error from Elasticsearch? You may not event need a break point, just look at the network traffic in the brower's dev tools.


First of all thank you so much for your reply. Unfortunately I cannot test it until monday since the visualization I'm referring to is being used in production and I have no access to those machines from home.

Though, I can tell you the test I made on version 7.4.1 was on a small part of the real data (stored on the 6.3.0), where the histogram visualization worked perfectly. How can it be so?

Also, if that was the problem, would increasing the elasticsearch.requestTimeout in the kibana.yml sort out the problem?

Hi there!

Ok I set higher values in the kibana.yml for kibana.autocompleteTimeout and kibana.autocompleteTerminateAfter parameters and it finally loads the visualizations the right way. It was a timeout problem then, because of the amount of docs loaded despite the short time range.

Thank you so much for you help!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.