A fresh variant of MapperParsingException


(Jack Park) #1

I created a gist for the mappings I am sending through node-es, with a
returned error:
MapperParsingException[Root type mapping not empty after parsing!

The gist is at

Note, that if I remove the upper portion of the json:
"topics": {
"mappings": {
"core": {
and just send in from "properties":, the same error occurs.

The exact code which sends mappings into node-es is found here:

I'm wondering if anyone recognizes an error in my mapping. I
deliberately include the index and type in the mapping. It seems hard
to find examples of schema mappings that do what I am trying to do.

Thanks!

Here is the error message:
ESClient-1 Error: {"error":"MapperParsingException[mapping [topics]]; nested: Ma
pperParsingException[Root type mapping not empty after parsing! Remaining fields
: [mappings : {core={properties={inOf={index=not_analyzed, store=true, type=stri
ng}, _ver={index=not_analyzed, store=true, type=string}, tpC={index=not_analyzed
, store=true, type=long}, lox={index=not_analyzed, store=true, type=string}, srt
Dt={index=not_analyzed, store=true, type=long}, url={index=not_analyzed, store=t
rue, type=string}, lists={properties={body={index=analyzed, store=true, type=str
ing}, sbOf={index=not_analyzed, store=true, type=string}, details={index=analyze
d, store=true, type=string}, psi={index=not_analyzed, store=true, type=string},
label={index=analyzed, store=true, type=string}, subj={index=analyzed, store=tru
e, type=string}}}}}}]]; ","status":400}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAH6s0fxkx%3D0ZpDM-qAEi4RREKKVubUcX%3DVSPSz5mwGTxYuWNNw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jun Ohtani) #2

hi,

you should not remove "core".
please try to add that.
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/indices-put-mapping.html

2014年8月12日火曜日、Jack Parkjackpark@topicquests.orgさんは書きました:

I created a gist for the mappings I am sending through node-es, with a
returned error:
MapperParsingException[Root type mapping not empty after parsing!

The gist is at
https://gist.github.com/KnowledgeGarden/b965b7e78f19f9be9025

Note, that if I remove the upper portion of the json:
"topics": {
"mappings": {
"core": {
and just send in from "properties":, the same error occurs.

The exact code which sends mappings into node-es is found here:
https://github.com/KnowledgeGarden/TQTopicMap/blob/master/lib/persist/es.js

I'm wondering if anyone recognizes an error in my mapping. I
deliberately include the index and type in the mapping. It seems hard
to find examples of schema mappings that do what I am trying to do.

Thanks!

Here is the error message:
ESClient-1 Error: {"error":"MapperParsingException[mapping [topics]];
nested: Ma
pperParsingException[Root type mapping not empty after parsing! Remaining
fields
: [mappings : {core={properties={inOf={index=not_analyzed, store=true,
type=stri
ng}, _ver={index=not_analyzed, store=true, type=string},
tpC={index=not_analyzed
, store=true, type=long}, lox={index=not_analyzed, store=true,
type=string}, srt
Dt={index=not_analyzed, store=true, type=long}, url={index=not_analyzed,
store=t
rue, type=string}, lists={properties={body={index=analyzed, store=true,
type=str
ing}, sbOf={index=not_analyzed, store=true, type=string},
details={index=analyze
d, store=true, type=string}, psi={index=not_analyzed, store=true,
type=string},
label={index=analyzed, store=true, type=string}, subj={index=analyzed,
store=tru
e, type=string}}}}}}]]; ","status":400}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com <javascript:;>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAH6s0fxkx%3D0ZpDM-qAEi4RREKKVubUcX%3DVSPSz5mwGTxYuWNNw%40mail.gmail.com
.
For more options, visit https://groups.google.com/d/optout.

--

Jun Ohtani
blog : http://blog.johtani.info

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAPW8A5zBLQNyrwX0HZwc6CECYV6H%3DqHUS5aKuy%2BCouO6b%2B9EtQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Jack Park) #3

Thanks!
The top level of my mappings.json is changed from the gist to look like this:

{
"core": {
"properties": {
"lox": {

And that appears to work.

On Tue, Aug 12, 2014 at 8:43 AM, Jun Ohtani johtani@gmail.com wrote:

hi,

you should not remove "core".
please try to add that.
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/indices-put-mapping.html

2014年8月12日火曜日、Jack Parkjackpark@topicquests.orgさんは書きました:

I created a gist for the mappings I am sending through node-es, with a
returned error:
MapperParsingException[Root type mapping not empty after parsing!

The gist is at
https://gist.github.com/KnowledgeGarden/b965b7e78f19f9be9025

Note, that if I remove the upper portion of the json:
"topics": {
"mappings": {
"core": {
and just send in from "properties":, the same error occurs.

The exact code which sends mappings into node-es is found here:

https://github.com/KnowledgeGarden/TQTopicMap/blob/master/lib/persist/es.js

I'm wondering if anyone recognizes an error in my mapping. I
deliberately include the index and type in the mapping. It seems hard
to find examples of schema mappings that do what I am trying to do.

Thanks!

Here is the error message:
ESClient-1 Error: {"error":"MapperParsingException[mapping [topics]];
nested: Ma
pperParsingException[Root type mapping not empty after parsing! Remaining
fields
: [mappings : {core={properties={inOf={index=not_analyzed, store=true,
type=stri
ng}, _ver={index=not_analyzed, store=true, type=string},
tpC={index=not_analyzed
, store=true, type=long}, lox={index=not_analyzed, store=true,
type=string}, srt
Dt={index=not_analyzed, store=true, type=long}, url={index=not_analyzed,
store=t
rue, type=string}, lists={properties={body={index=analyzed, store=true,
type=str
ing}, sbOf={index=not_analyzed, store=true, type=string},
details={index=analyze
d, store=true, type=string}, psi={index=not_analyzed, store=true,
type=string},
label={index=analyzed, store=true, type=string}, subj={index=analyzed,
store=tru
e, type=string}}}}}}]]; ","status":400}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAH6s0fxkx%3D0ZpDM-qAEi4RREKKVubUcX%3DVSPSz5mwGTxYuWNNw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--

Jun Ohtani
blog : http://blog.johtani.info

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAPW8A5zBLQNyrwX0HZwc6CECYV6H%3DqHUS5aKuy%2BCouO6b%2B9EtQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAH6s0fzQvAoXbEbJ09Fdit6HF_nzJqZ7kRac9MAZ8rrqtHRE%2Bw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4