Add non existing settings in cluster settings in elasticsearch

Hi there,

Recently i have built elasticsearch with fluentd and Kibana and all is working fine, but we are facing high cpu load while performing search caused by java.

I have 60 GB Ram and 16 processors and each processor has 2 cores.

ES_HEAP_SIZE=32g
-find below more details

curl "localhost:9200/_cat/thread_pool?v&h=search.rejected"
search.rejected
387

curl "localhost:9200/_cat/thread_pool?v&h=index.rejected"
index.rejected
0

  • snapshot from elasticsearch.log

[DEBUG][action.search.type ] [Hulk 2099] [logstash-2015.03.14][4], node[qxcAN3lURs65Lf1GMhB_qg], [P], s[STARTED]: Failed to execute [org.elasticsearch.action.search.SearchRequest@7c71025f] lastShard [true]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException: rejected execution (queue capacity 1000) on org.elasticsearch.search.action.SearchServiceTransportAction$23@1d7c9f0f
at org.elasticsearch.common.util.concurrent.EsAbortPolicy.rejectedExecution(EsAbortPolicy.java:62)
at java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:821)
at java.util.concurrent.ThreadPoolExecutor.execute(ThreadPoolExecutor.java:1372)
at org.elasticsearch.search.action.SearchServiceTransportAction.execute(SearchServiceTransportAction.java:551)
at org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteQuery(SearchServiceTransportAction.java:228)
at org.elasticsearch.action.search.type.TransportSearchCountAction$AsyncAction.sendExecuteFirstPhase(TransportSearchCountAction.java:71)
at org.elasticsearch.action.search.type.TransportSearchTypeAction$BaseAsyncAction.performFirstPhase(TransportSearchTypeAction.java:171)

Now i read that i have to update the threadpool settings in ES and i have now
curl -XGET localhost:9200/_cluster/settings?pretty
{
"persistent" : { },
"transient" : { }
}

i'm trying to update the settings with the below commands

curl -XPUT localhost:9200/_cluster/settings -d '{

"threadpool" : {
"index": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"bulk": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"search": {
"type": "fixed",
"size": 96,
"queue_size": 1000
}
}
}'

but i keep getting {"error":"ActionRequestValidationException[Validation Failed: 1: no settings to update;]","status":400}

What's wrong with this command? is it the right solution for my issue ?

Please advise

Thanks.

Ayman

You should drop your heap to 31GB, look for java pointer compression if you
want to know more.

If your threadpools are filling up then your node is overloaded and you
need more nodes. Take a look at
http://www.elastic.co/guide/en/elasticsearch/guide/current/_don_8217_t_touch_these_settings.html#_threadpools

On 29 March 2015 at 02:09, Ayman aymanshorman@gmail.com wrote:

Hi there,

Recently i have built elasticsearch with fluentd and Kibana and all is
working fine, but we are facing high cpu load while performing search
caused
by java.

I have 60 GB Ram and 16 processors and each processor has 2 cores.

ES_HEAP_SIZE=32g
-find below more details

curl "localhost:9200/_cat/thread_pool?v&h=search.rejected"
search.rejected
387

curl "localhost:9200/_cat/thread_pool?v&h=index.rejected"
index.rejected
0

  • snapshot from elasticsearch.log

[DEBUG][action.search.type ] [Hulk 2099] [logstash-2015.03.14][4],
node[qxcAN3lURs65Lf1GMhB_qg], [P], s[STARTED]: Failed to execute
[org.elasticsearch.action.search.SearchRequest@7c71025f] lastShard [true]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException:
rejected execution (queue capacity 1000) on
org.elasticsearch.search.action.SearchServiceTransportAction$23@1d7c9f0f
at

org.elasticsearch.common.util.concurrent.EsAbortPolicy.rejectedExecution(EsAbortPolicy.java:62)
at
java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:821)
at

java.util.concurrent.ThreadPoolExecutor.execute(ThreadPoolExecutor.java:1372)
at

org.elasticsearch.search.action.SearchServiceTransportAction.execute(SearchServiceTransportAction.java:551)
at

org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteQuery(SearchServiceTransportAction.java:228)
at

org.elasticsearch.action.search.type.TransportSearchCountAction$AsyncAction.sendExecuteFirstPhase(TransportSearchCountAction.java:71)
at

org.elasticsearch.action.search.type.TransportSearchTypeAction$BaseAsyncAction.performFirstPhase(TransportSearchTypeAction.java:171)

Now i read that i have to update the threadpool settings in ES and i have
now
curl -XGET localhost:9200/_cluster/settings?pretty
{
"persistent" : { },
"transient" : { }
}

i'm trying to update the settings with the below commands

curl -XPUT localhost:9200/_cluster/settings -d '{

"threadpool" : {
"index": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"bulk": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"search": {
"type": "fixed",
"size": 96,
"queue_size": 1000
}
}
}'

but i keep getting {"error":"ActionRequestValidationException[Validation
Failed: 1: no settings to update;]","status":400}

What's wrong with this command? is it the right solution for my issue ?

Please advise

Thanks.

Ayman

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/Add-non-existing-settings-in-cluster-settings-in-elasticsearch-tp4072768.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1427555353485-4072768.post%40n3.nabble.com
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9ZJm_iXOA7%2B83EsLsoE7%2Bk%3DUg1rMWnY_fa2it_BNuePw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

I dropped the HEAP size to 31g as per your recommendation but i still have
issues.

Sorry i'm newbie to elasticsearch can you please guide me to add new node
without losing the current indexed data?

I have attached screenshot from my cluster.

I'm having high load when trying to execute a bulk of queries

On Sunday, March 29, 2015 at 10:15:27 AM UTC+3, Ayman Shorman wrote:

Hi there,

Recently i have built elasticsearch with fluentd and Kibana and all is
working fine, but we are facing high cpu load while performing search
caused
by java.

I have 60 GB Ram and 16 processors and each processor has 2 cores.

ES_HEAP_SIZE=32g
-find below more details

curl "localhost:9200/_cat/thread_pool?v&h=search.rejected"
search.rejected
387

curl "localhost:9200/_cat/thread_pool?v&h=index.rejected"
index.rejected
0

  • snapshot from elasticsearch.log

[DEBUG][action.search.type ] [Hulk 2099] [logstash-2015.03.14][4],
node[qxcAN3lURs65Lf1GMhB_qg], [P], s[STARTED]: Failed to execute
[org.elasticsearch.action.search.SearchRequest@7c71025f] lastShard [true]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException:
rejected execution (queue capacity 1000) on
org.elasticsearch.search.action.SearchServiceTransportAction$23@1d7c9f0f
at
org.elasticsearch.common.util.concurrent.EsAbortPolicy.rejectedExecution(EsAbortPolicy.java:62)

    at 

java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:821)

    at 

java.util.concurrent.ThreadPoolExecutor.execute(ThreadPoolExecutor.java:1372)

    at 

org.elasticsearch.search.action.SearchServiceTransportAction.execute(SearchServiceTransportAction.java:551)

    at 

org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteQuery(SearchServiceTransportAction.java:228)

    at 

org.elasticsearch.action.search.type.TransportSearchCountAction$AsyncAction.sendExecuteFirstPhase(TransportSearchCountAction.java:71)

    at 

org.elasticsearch.action.search.type.TransportSearchTypeAction$BaseAsyncAction.performFirstPhase(TransportSearchTypeAction.java:171)

Now i read that i have to update the threadpool settings in ES and i have
now
curl -XGET localhost:9200/_cluster/settings?pretty
{
"persistent" : { },
"transient" : { }
}

i'm trying to update the settings with the below commands

curl -XPUT localhost:9200/_cluster/settings -d '{

"threadpool" : {
"index": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"bulk": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"search": {
"type": "fixed",
"size": 96,
"queue_size": 1000
}
}
}'

but i keep getting {"error":"ActionRequestValidationException[Validation
Failed: 1: no settings to update;]","status":400}

What's wrong with this command? is it the right solution for my issue ?

Please advise

Thanks.

Ayman

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/Add-non-existing-settings-in-cluster-settings-in-elasticsearch-tp4072768.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8559b221-233e-40cd-838e-2feb2163b2f3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

What version are you on, what OS, what java version and release, how much
data do you have in the cluster, how are you monitoring the cluster?

On 29 March 2015 at 02:09, Ayman aymanshorman@gmail.com wrote:

Hi there,

Recently i have built elasticsearch with fluentd and Kibana and all is
working fine, but we are facing high cpu load while performing search
caused
by java.

I have 60 GB Ram and 16 processors and each processor has 2 cores.

ES_HEAP_SIZE=32g
-find below more details

curl "localhost:9200/_cat/thread_pool?v&h=search.rejected"
search.rejected
387

curl "localhost:9200/_cat/thread_pool?v&h=index.rejected"
index.rejected
0

  • snapshot from elasticsearch.log

[DEBUG][action.search.type ] [Hulk 2099] [logstash-2015.03.14][4],
node[qxcAN3lURs65Lf1GMhB_qg], [P], s[STARTED]: Failed to execute
[org.elasticsearch.action.search.SearchRequest@7c71025f] lastShard [true]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException:
rejected execution (queue capacity 1000) on
org.elasticsearch.search.action.SearchServiceTransportAction$23@1d7c9f0f
at

org.elasticsearch.common.util.concurrent.EsAbortPolicy.rejectedExecution(EsAbortPolicy.java:62)
at
java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:821)
at

java.util.concurrent.ThreadPoolExecutor.execute(ThreadPoolExecutor.java:1372)
at

org.elasticsearch.search.action.SearchServiceTransportAction.execute(SearchServiceTransportAction.java:551)
at

org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteQuery(SearchServiceTransportAction.java:228)
at

org.elasticsearch.action.search.type.TransportSearchCountAction$AsyncAction.sendExecuteFirstPhase(TransportSearchCountAction.java:71)
at

org.elasticsearch.action.search.type.TransportSearchTypeAction$BaseAsyncAction.performFirstPhase(TransportSearchTypeAction.java:171)

Now i read that i have to update the threadpool settings in ES and i have
now
curl -XGET localhost:9200/_cluster/settings?pretty
{
"persistent" : { },
"transient" : { }
}

i'm trying to update the settings with the below commands

curl -XPUT localhost:9200/_cluster/settings -d '{

"threadpool" : {
"index": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"bulk": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"search": {
"type": "fixed",
"size": 96,
"queue_size": 1000
}
}
}'

but i keep getting {"error":"ActionRequestValidationException[Validation
Failed: 1: no settings to update;]","status":400}

What's wrong with this command? is it the right solution for my issue ?

Please advise

Thanks.

Ayman

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/Add-non-existing-settings-in-cluster-settings-in-elasticsearch-tp4072768.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1427555353485-4072768.post%40n3.nabble.com
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9R%2BrbcZDyvTLZu3fe6W20%3DQnzFmoXLa7dgP%2BXrJDV9Aw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

  • OS: Linux - Redhat 5.2
  • Elasticsearch version: 1.4.4
  • Java: 1.7.0_75
  • Data: i have now around 200GB, around 5 ~ 7 GB daily.
  • I'm using Kibana 4
  • I have 60GB RAM 30GB as HEAP size.

On Monday, April 6, 2015 at 3:18:28 AM UTC+3, Mark Walkom wrote:

What version are you on, what OS, what java version and release, how much
data do you have in the cluster, how are you monitoring the cluster?

On 29 March 2015 at 02:09, Ayman <aymans...@gmail.com <javascript:>>
wrote:

Hi there,

Recently i have built elasticsearch with fluentd and Kibana and all is
working fine, but we are facing high cpu load while performing search
caused
by java.

I have 60 GB Ram and 16 processors and each processor has 2 cores.

ES_HEAP_SIZE=32g
-find below more details

curl "localhost:9200/_cat/thread_pool?v&h=search.rejected"
search.rejected
387

curl "localhost:9200/_cat/thread_pool?v&h=index.rejected"
index.rejected
0

  • snapshot from elasticsearch.log

[DEBUG][action.search.type ] [Hulk 2099] [logstash-2015.03.14][4],
node[qxcAN3lURs65Lf1GMhB_qg], [P], s[STARTED]: Failed to execute
[org.elasticsearch.action.search.SearchRequest@7c71025f] lastShard [true]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException:
rejected execution (queue capacity 1000) on
org.elasticsearch.search.action.SearchServiceTransportAction$23@1d7c9f0f
at

org.elasticsearch.common.util.concurrent.EsAbortPolicy.rejectedExecution(EsAbortPolicy.java:62)
at

java.util.concurrent.ThreadPoolExecutor.reject(ThreadPoolExecutor.java:821)
at

java.util.concurrent.ThreadPoolExecutor.execute(ThreadPoolExecutor.java:1372)
at

org.elasticsearch.search.action.SearchServiceTransportAction.execute(SearchServiceTransportAction.java:551)
at

org.elasticsearch.search.action.SearchServiceTransportAction.sendExecuteQuery(SearchServiceTransportAction.java:228)
at

org.elasticsearch.action.search.type.TransportSearchCountAction$AsyncAction.sendExecuteFirstPhase(TransportSearchCountAction.java:71)
at

org.elasticsearch.action.search.type.TransportSearchTypeAction$BaseAsyncAction.performFirstPhase(TransportSearchTypeAction.java:171)

Now i read that i have to update the threadpool settings in ES and i have
now
curl -XGET localhost:9200/_cluster/settings?pretty
{
"persistent" : { },
"transient" : { }
}

i'm trying to update the settings with the below commands

curl -XPUT localhost:9200/_cluster/settings -d '{

"threadpool" : {
"index": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"bulk": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"search": {
"type": "fixed",
"size": 96,
"queue_size": 1000
}
}
}'

but i keep getting {"error":"ActionRequestValidationException[Validation
Failed: 1: no settings to update;]","status":400}

What's wrong with this command? is it the right solution for my issue ?

Please advise

Thanks.

Ayman

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/Add-non-existing-settings-in-cluster-settings-in-elasticsearch-tp4072768.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1427555353485-4072768.post%40n3.nabble.com
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0b407b66-3d40-45c3-ba45-df7ce8170f13%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

And how are you monitoring the cluster?
That part is important as you need to find out what is putting pressure on
your system to start backing up the queue.

On 6 April 2015 at 19:17, Ayman Shorman aymanshorman@gmail.com wrote:

  • OS: Linux - Redhat 5.2
  • Elasticsearch version: 1.4.4
  • Java: 1.7.0_75
  • Data: i have now around 200GB, around 5 ~ 7 GB daily.
  • I'm using Kibana 4
  • I have 60GB RAM 30GB as HEAP size.

On Monday, April 6, 2015 at 3:18:28 AM UTC+3, Mark Walkom wrote:

What version are you on, what OS, what java version and release, how much
data do you have in the cluster, how are you monitoring the cluster?

On 29 March 2015 at 02:09, Ayman aymans...@gmail.com wrote:

Hi there,

Recently i have built elasticsearch with fluentd and Kibana and all is
working fine, but we are facing high cpu load while performing search
caused
by java.

I have 60 GB Ram and 16 processors and each processor has 2 cores.

ES_HEAP_SIZE=32g
-find below more details

curl "localhost:9200/_cat/thread_pool?v&h=search.rejected"
search.rejected
387

curl "localhost:9200/_cat/thread_pool?v&h=index.rejected"
index.rejected
0

  • snapshot from elasticsearch.log

[DEBUG][action.search.type ] [Hulk 2099] [logstash-2015.03.14][4],
node[qxcAN3lURs65Lf1GMhB_qg], [P], s[STARTED]: Failed to execute
[org.elasticsearch.action.search.SearchRequest@7c71025f] lastShard
[true]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException:
rejected execution (queue capacity 1000) on
org.elasticsearch.search.action.SearchServiceTransportAction$23@1d7c9f0f
at
org.elasticsearch.common.util.concurrent.EsAbortPolicy.
rejectedExecution(EsAbortPolicy.java:62)
at
java.util.concurrent.ThreadPoolExecutor.reject(
ThreadPoolExecutor.java:821)
at
java.util.concurrent.ThreadPoolExecutor.execute(
ThreadPoolExecutor.java:1372)
at
org.elasticsearch.search.action.SearchServiceTransportAction.execute(
SearchServiceTransportAction.java:551)
at
org.elasticsearch.search.action.SearchServiceTransportAction.
sendExecuteQuery(SearchServiceTransportAction.java:228)
at
org.elasticsearch.action.search.type.TransportSearchCountAction$
AsyncAction.sendExecuteFirstPhase(TransportSearchCountAction.java:71)
at
org.elasticsearch.action.search.type.TransportSearchTypeAction$
BaseAsyncAction.performFirstPhase(TransportSearchTypeAction.java:171)

Now i read that i have to update the threadpool settings in ES and i have
now
curl -XGET localhost:9200/_cluster/settings?pretty
{
"persistent" : { },
"transient" : { }
}

i'm trying to update the settings with the below commands

curl -XPUT localhost:9200/_cluster/settings -d '{

"threadpool" : {
"index": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"bulk": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"search": {
"type": "fixed",
"size": 96,
"queue_size": 1000
}
}
}'

but i keep getting {"error":"ActionRequestValidationException[Validation
Failed: 1: no settings to update;]","status":400}

What's wrong with this command? is it the right solution for my issue ?

Please advise

Thanks.

Ayman

--
View this message in context: http://elasticsearch-users.
115913.n3.nabble.com/Add-non-existing-settings-in-cluster-
settings-in-elasticsearch-tp4072768.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/1427555353485-4072768.post%40n3.nabble.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0b407b66-3d40-45c3-ba45-df7ce8170f13%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/0b407b66-3d40-45c3-ba45-df7ce8170f13%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X84JXHUzm6FnBpsDPcuA%3DE6s7%3DharD442gmbn_Ln%3DMbyw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi Mark,
Not sure what do you mean, but i use elasticsearch-head plugin.

On Tuesday, April 7, 2015 at 12:09:16 AM UTC+3, Mark Walkom wrote:

And how are you monitoring the cluster?
That part is important as you need to find out what is putting pressure on
your system to start backing up the queue.

On 6 April 2015 at 19:17, Ayman Shorman <aymans...@gmail.com <javascript:>

wrote:

  • OS: Linux - Redhat 5.2
  • Elasticsearch version: 1.4.4
  • Java: 1.7.0_75
  • Data: i have now around 200GB, around 5 ~ 7 GB daily.
  • I'm using Kibana 4
  • I have 60GB RAM 30GB as HEAP size.

On Monday, April 6, 2015 at 3:18:28 AM UTC+3, Mark Walkom wrote:

What version are you on, what OS, what java version and release, how
much data do you have in the cluster, how are you monitoring the cluster?

On 29 March 2015 at 02:09, Ayman aymans...@gmail.com wrote:

Hi there,

Recently i have built elasticsearch with fluentd and Kibana and all is
working fine, but we are facing high cpu load while performing search
caused
by java.

I have 60 GB Ram and 16 processors and each processor has 2 cores.

ES_HEAP_SIZE=32g
-find below more details

curl "localhost:9200/_cat/thread_pool?v&h=search.rejected"
search.rejected
387

curl "localhost:9200/_cat/thread_pool?v&h=index.rejected"
index.rejected
0

  • snapshot from elasticsearch.log

[DEBUG][action.search.type ] [Hulk 2099] [logstash-2015.03.14][4],
node[qxcAN3lURs65Lf1GMhB_qg], [P], s[STARTED]: Failed to execute
[org.elasticsearch.action.search.SearchRequest@7c71025f] lastShard
[true]
org.elasticsearch.common.util.concurrent.EsRejectedExecutionException:
rejected execution (queue capacity 1000) on
org.elasticsearch.search.action.SearchServiceTransportAction$
23@1d7c9f0f
at
org.elasticsearch.common.util.concurrent.EsAbortPolicy.
rejectedExecution(EsAbortPolicy.java:62)
at
java.util.concurrent.ThreadPoolExecutor.reject(
ThreadPoolExecutor.java:821)
at
java.util.concurrent.ThreadPoolExecutor.execute(
ThreadPoolExecutor.java:1372)
at
org.elasticsearch.search.action.SearchServiceTransportAction.execute(
SearchServiceTransportAction.java:551)
at
org.elasticsearch.search.action.SearchServiceTransportAction.
sendExecuteQuery(SearchServiceTransportAction.java:228)
at
org.elasticsearch.action.search.type.TransportSearchCountAction$
AsyncAction.sendExecuteFirstPhase(TransportSearchCountAction.java:71)
at
org.elasticsearch.action.search.type.TransportSearchTypeAction$
BaseAsyncAction.performFirstPhase(TransportSearchTypeAction.java:171)

Now i read that i have to update the threadpool settings in ES and i
have
now
curl -XGET localhost:9200/_cluster/settings?pretty
{
"persistent" : { },
"transient" : { }
}

i'm trying to update the settings with the below commands

curl -XPUT localhost:9200/_cluster/settings -d '{

"threadpool" : {
"index": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"bulk": {
"type": "fixed",
"size": 32,
"queue_size": 1000
},
"search": {
"type": "fixed",
"size": 96,
"queue_size": 1000
}
}
}'

but i keep getting {"error":"ActionRequestValidationExcepti
on[Validation
Failed: 1: no settings to update;]","status":400}

What's wrong with this command? is it the right solution for my issue ?

Please advise

Thanks.

Ayman

--
View this message in context: http://elasticsearch-users.
115913.n3.nabble.com/Add-non-existing-settings-in-cluster-
settings-in-elasticsearch-tp4072768.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/1427555353485-4072768.post%40n3.nabble.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/0b407b66-3d40-45c3-ba45-df7ce8170f13%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/0b407b66-3d40-45c3-ba45-df7ce8170f13%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0a2a2384-d09b-482d-a087-7606f0915c0f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.