Adding a second to cluster - Kibana Errors


(Stephen) #1

Hello,

I am currently trying to create a 2 node cluster and have been facing issues which are on this thread. it has been recommended I bring my question to the Kibana forum.

In my Elasticsearch configuration I have the following to enable the secondary node:

discovery.zen.ping.unicast.hosts: ["192.168.0.64", "192.168.0.139"]
discovery.zen.minimum_master_nodes: 2

I have this config in the 2 nodes I am trying to setup. When i start Elasticsearch on both nodes, there is no errors in the logs, both start gracefully. On the main node, when I start Kibana however with the discovery.zen.minimum_master_nodes set to 2, I see the following errors in Kibana:

kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-01-14 10:59:14 GMT; 1min 59s ago
 Main PID: 8050 (node)
    Tasks: 10
   Memory: 265.2M
      CPU: 5.821s
   CGroup: /system.slice/kibana.service
           └─8050 /usr/share/kibana/bin/../node/bin/node --no-warnings /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml

Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:watcher@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with license i
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:index_management@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:rollup@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with license in
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:graph@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with license inf
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:spaces@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with license in
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:security@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with license
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:grokdebugger@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with lice
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:logstash@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with license
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:beats_management@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with
Jan 14 10:59:35 192.168.0.64 kibana[8050]: {"type":"log","@timestamp":"2019-01-14T10:59:35Z","tags":["status","plugin:reporting@6.5.2","error"],"pid":8050,"state":"red","message":"Status changed from red to red - [data] Elasticsearch cluster did not respond with license

If I change it back to 1, it works as a single node cluster with no issues or errors. I have been reading on the forums trying to find a solution but I can't seem to find anything. Ideally I would like to have 1 Main node with Elasticsearch, Kibana, Logstash and 1 Secondary node with Elasticsearch. But I can't seem to get the two to work together. Any help would be appreciated.


Can't see the second node whilst attempting to build a cluster
(Stephen) #2

Hello,

I have once again tried adding a new second node and I am still seeing the following errors. When I change discovery.zen.minimum_master_nodes to 2, I get the license errors. If I change it to 1, it works, but doesn't recognise the second node. Both nodes have the same cluster name. With .64 having the master.node flag to true, and the .139 having the data.node to true.

Any help would be greatly appreciated.


(Tim Sullivan) #3

I read up on this and I think it's mostly likely X-Pack security configuration with ES, so I replied on the original post: Can't see the second node whilst attempting to build a cluster


(Stephen) #4

This problem was resolved in this thread: Resolution

The main problem was in the Elasticsearch config file where I had set the network.host to localhost. I changed it to the main IP address which then allowed the cluster to see each other.


(system) closed #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.