Adding indices to New Spaces - not able to

I am creating new spaces for grouping our users together with their appropriate feeds. But I cannot see the feeds within the new space, when i try to add them into the Index Patterns. Now, as a user in the default space, i can access those particular indices (the ones i'd like to add to the Space). But when I search index patterns in the new space, the indices do not show up as an option at all. I have a role created, and tied to the new space. That role is tied to the indices in question as well. (those came up as options with role setup). So i am perplexed as why I cannot add those indices to the Space, under that role. Can anyone help or guide me on how to fix this and get the indices into the new Space?

Thanks!

Index pattern is a local object. Each space will have its own.
So you need to create new index patterns for each new space.

I am trying to create a new index pattern under that Space, but the option of the indices I want are not showing up as options. None of the indices are showing up as options. I have specifically added the start of the indices with * and even put a specific one in the permissions for the space and the role i am attaching to the space, and those still not an option when trying to create the index pattern. I would think, since it's showing in the default space, that those indices are coming into the cluster/s and thus, can pull those into the new Space for specific monitoring, setting up the index pattern. I have done this on a cluster with slightly older version, but this is newer 7.8 I think, and seems to be giving me issues.

So i am trying to deduce if there is some extra bit in creating spaces and setting up feeds in those spaces. In the ones I did in the 6.8 versions awhile back, I don't recall having this issue.

I hope that makes sense.

Try with a superuser.
If it works there (it should) then you have a misconfigured role.

I have been doing it as a super user. I have also tested as a normal kibana user, with permissions to that space and those indices. I have a ticket open at the moment, as even my support guy couldn't figure out why it wasn't adding them.

He did mention trying import/export into the space. but i can't get that to work either.

1 Like