All primary shards are in same node. Why? Version 1.1.1


(Santiago Ferrer Deheza) #1

Hi everyone!

Im having a doubt regards my elastic cluster. Here is a picture of the head
plugin....

https://lh3.googleusercontent.com/-A1xK6Rk6U8w/U44jmdSDLGI/AAAAAAAAAOs/mvq8of-mVvo/s1600/Screen+Shot+2014-06-03+at+14.30.01.png
Here you can see that all primary shards are in the same node and not
distributed. I shutdown the master node to see if the primary shards were
going to be distributed in both nodes left but this is what happened.

https://lh5.googleusercontent.com/-5KbBNVtm114/U44lCzj7A_I/AAAAAAAAAO8/wvc2txaoc88/s1600/Screen+Shot+2014-06-03+at+14.35.04.png

All primary shards were allocated in a single node. Is this behaviour
right? I would prefer them to be distributed equally among all nodes so the
writing operations are not handled by a single one. Know how to do that?

This is my elasticsearch.yml

##################### ElasticSearch Configuration Example
#####################

# Cluster name identifies your cluster for auto-discovery. If you're
running

# multiple clusters on the same network, make sure you're using unique
names.

#
cluster.name: mclics

action.auto_create_index: false

index.number_of_shards: 16

index.number_of_replicas: 2

action.disable_delete_all_indices: true

path.data: /mnt/elasticsearch

path.logs: /usr/local/log

bootstrap.mlockall: true

gateway.recover_after_nodes: 2

gateway.expected_nodes: 3

discovery.zen.minimum_master_nodes: 1

discovery.zen.ping.unicast.hosts: [##hosts##]

Thanks,
Santiago!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/93af689a-e14d-4047-95be-7f32ed730a1e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

Primary shards are addressed first when writing, but it is a myth they do
all the writing. Secondary shards do the writing too, but only some milli
seconds later. There is nothing to worry about.

Jörg

On Tue, Jun 3, 2014 at 9:49 PM, Santiago Ferrer Deheza <
sa.ferrer.deheza@gmail.com> wrote:

Hi everyone!

Im having a doubt regards my elastic cluster. Here is a picture of the
head plugin....

https://lh3.googleusercontent.com/-A1xK6Rk6U8w/U44jmdSDLGI/AAAAAAAAAOs/mvq8of-mVvo/s1600/Screen+Shot+2014-06-03+at+14.30.01.png
Here you can see that all primary shards are in the same node and not
distributed. I shutdown the master node to see if the primary shards were
going to be distributed in both nodes left but this is what happened.

https://lh5.googleusercontent.com/-5KbBNVtm114/U44lCzj7A_I/AAAAAAAAAO8/wvc2txaoc88/s1600/Screen+Shot+2014-06-03+at+14.35.04.png

All primary shards were allocated in a single node. Is this behaviour
right? I would prefer them to be distributed equally among all nodes so the
writing operations are not handled by a single one. Know how to do that?

This is my elasticsearch.yml

##################### ElasticSearch Configuration Example
#####################

# Cluster name identifies your cluster for auto-discovery. If you're
running

# multiple clusters on the same network, make sure you're using unique
names.

#
cluster.name http://cluster.name: mclics

action.auto_create_index: false

index.number_of_shards: 16

index.number_of_replicas: 2

action.disable_delete_all_indices: true

path.data: /mnt/elasticsearch

path.logs: /usr/local/log

bootstrap.mlockall: true

gateway.recover_after_nodes: 2

gateway.expected_nodes: 3

discovery.zen.minimum_master_nodes: 1

discovery.zen.ping.unicast.hosts: [##hosts##]

Thanks,
Santiago!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/93af689a-e14d-4047-95be-7f32ed730a1e%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/93af689a-e14d-4047-95be-7f32ed730a1e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoGAWMbxKMHQnVOwtq-1jnSu9p2D_rUD8LhydeyJuQjLXA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Santiago Ferrer Deheza) #3

Jörg, Thanks for the quick answer!

On Tuesday, June 3, 2014 4:53:16 PM UTC-3, Jörg Prante wrote:

Primary shards are addressed first when writing, but it is a myth they do
all the writing. Secondary shards do the writing too, but only some milli
seconds later. There is nothing to worry about.

Jörg

On Tue, Jun 3, 2014 at 9:49 PM, Santiago Ferrer Deheza <
sa.ferre...@gmail.com <javascript:>> wrote:

Hi everyone!

Im having a doubt regards my elastic cluster. Here is a picture of the
head plugin....

https://lh3.googleusercontent.com/-A1xK6Rk6U8w/U44jmdSDLGI/AAAAAAAAAOs/mvq8of-mVvo/s1600/Screen+Shot+2014-06-03+at+14.30.01.png
Here you can see that all primary shards are in the same node and not
distributed. I shutdown the master node to see if the primary shards were
going to be distributed in both nodes left but this is what happened.

https://lh5.googleusercontent.com/-5KbBNVtm114/U44lCzj7A_I/AAAAAAAAAO8/wvc2txaoc88/s1600/Screen+Shot+2014-06-03+at+14.35.04.png

All primary shards were allocated in a single node. Is this behaviour
right? I would prefer them to be distributed equally among all nodes so the
writing operations are not handled by a single one. Know how to do that?

This is my elasticsearch.yml

##################### ElasticSearch Configuration Example
#####################

# Cluster name identifies your cluster for auto-discovery. If you're
running

# multiple clusters on the same network, make sure you're using unique
names.

#
cluster.name http://cluster.name: mclics

action.auto_create_index: false

index.number_of_shards: 16

index.number_of_replicas: 2

action.disable_delete_all_indices: true

path.data: /mnt/elasticsearch

path.logs: /usr/local/log

bootstrap.mlockall: true

gateway.recover_after_nodes: 2

gateway.expected_nodes: 3

discovery.zen.minimum_master_nodes: 1

discovery.zen.ping.unicast.hosts: [##hosts##]

Thanks,
Santiago!

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/93af689a-e14d-4047-95be-7f32ed730a1e%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/93af689a-e14d-4047-95be-7f32ed730a1e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/29833671-7b72-423c-9b21-1a42a0e72e97%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4