Annotations for code deployments


#1

I am looking to add annotations to Kibana for when new versions of code are deployed. During a demo today, I saw annotations during a machine learning demo. I had read annotations are only supported for anomaly detection, and can't be added outside of this. But in the demo, I thought he said it came from another source.

Ideally, I would like a Step in Octopus Deploy that sends a document to elasticsearch. I have seen something similar in LogicMonitor, and it was very helpful.

Is this possible?

Thanks!


(Mark Walkom) #2

Does https://www.elastic.co/blog/time-series-annotations-and-anomalies-with-kibana align with what you have seen?


#3

Thanks warkolm. I have seen that blog article before, very helpful and we definitely intend to use that technique.

Unfortunately, those annotations are coming from anomaly detection. I don't see how we could manually create an annotation. "how to add annotations to a time series visualization from anomalies detected by a machine learning job."


(Mark Walkom) #4

You can add annotations with TSVB, see https://www.elastic.co/guide/en/kibana/current/time-series-interface.html#_annotations_tab


#5

Thanks @warkolm. I was able to get pretty far with implementing this. Unfortunately I believe I hit a bug, and I don't think it will work.

Basically I can't use the new annotation index I created because the time field can not be selected. This seems like a continuation of the bug reported here: https://github.com/elastic/kibana/issues/22575
In my case I also have this problem, where non default indexes can't have their time field selected, on the annotation tab as well.


#6

This started working. I wish I knew what exactly got it working.

I stayed on the panel options tab and tried a few indexes as I did before. I chose my annotations index and typed in @timestamp. The dropdown had an error, which is where I got stuck before. I then typed in the name of my iis index. Once that name was in, the Time Field box autopopulated, but also left the old value. So I had @timestamp in there twice.

After that I was able to switch back to my annotations index, and one of the @timestamp values stayed populated! After that I was able to go to the annotations tab and typing in my annotations index caused the time field box to autopopulate.

I used @timestamp for my time field for both annotations and my filebeat IIS logs, which is why I think this worked. I am using the latest chrome browser.


#7

I found a better work around for the no timeseries on non-default indexes bug. This bug presents itself on both panel options as well as annotations tabs of time series visual builder.

Step 1: Ensure your primary index for visualization is the default.
Step 2: Fill in panel options pane of visual builder, will probably autopopulate.
Step 3: Go to annotations tab, type in name of secondary index.
Step 4: In a separate browser tab, go to Management, and change the secondary index to be default index.
Step 5: Go back to original browser tab, should still be on annotations. Press ctrl-f5.
Step 6: The timeseries drop should now be populated correctly in annotations. SAVE.
Step 7: Optional: Change the default index back to the original if desired, but the visualization should be regardless.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.