APM menu does not showing up in in kibana (self hosted)


(Cabrinoob) #1

Hi,
I'am running Elasticsearch 6.4.1 on Kubernetes (docker.elastic.co/elasticsearch/elasticsearch:6.4.1). I enabled X-Pack too.

I Have installed APM-Server 6.2.4 and everything is working fine : I have data coming from my instrumented nodeJS apps. I also imported APM dashboards.

BUT the APM UI does not showing up in the left menu.

What I've missed?


(Søren Louv Jansen) #2

Hi,

That sounds odd. A few steps that might highlight the issue:

  1. Please double check, that your license for x-pack is valid: Management -> License Management.
  2. Try accessing <host>/app/apm directly, and see if that brings up the APM UI?
  3. Ensure that the following config options are not disabled in config/kibana.yml:
apm_oss.enabled = true
xpack.apm.enabled: true
xpack.apm.ui.enabled: true

Let me know how it goes.


(Cabrinoob) #3

Ok, I found the problem : The Docker image of Kibana was pointing on the kibana-oss version. Using the non-oss one resolved my problem.

Now I have "APM" in the left menu.

Thank you


(system) #4

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.