Authorization Exception Kibana 6.3


(Jagadeesh Kumar Ck) #1

Hii
I downloaded the Kibana 6.3.3 git hub and run the code using the command

yarn start --no-base-path --oss

I use elastic search as a service from aws as a the elastic search and then it is showing an error

server log [07:38:47.804] [error][status][plugin:elasticsearch@6.3.3] Status changed from yellow to red - Authorization Exception

But when i run the same code by changing the elasticsearch url to localhost:9200 and running elasticsearch on my local machine the system works fine

It is showing the error only when it is connected to aws elasticsearch


(kulkarni) #2

Probably we need to see your kibana.yml to know more, but it sounds like you could be missing elasticsearch.username and elasticsearch.password.

Thanks
Rashmi


(Jagadeesh Kumar Ck) #3

This is my kibana config.yml

# xpack.security.enabled: false

console.enabled: false

# Kibana is served by a back end server. This setting specifies the port to use.

#server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.

# The default is 'localhost', which usually means remote machines will not be able to connect.

# To allow connections from remote users, set this parameter to a non-loopback address.

#server.host: "localhost"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.

# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath

# from requests it receives, and to prevent a deprecation warning at startup.

# This setting cannot end in a slash.

#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with

# `server.basePath` or require that they are rewritten by your reverse proxy.

# This setting was effectively always `false` before Kibana 6.3 and will

# default to `true` starting in Kibana 7.0.

#server.rewriteBasePath: false

# The maximum payload size in bytes for incoming server requests.

#server.maxPayloadBytes: 1048576

# The Kibana server's name. This is used for display purposes.

#server.name: "your-hostname"

# The URL of the Elasticsearch instance to use for all your queries.#

# elasticsearch.url: "http://localhost:9200"

elasticsearch.url: "https://search-cyberbs-es-6-3-k46jbctziltkkv7hnyx6vh5jyi.eu-west-3.es.amazonaws.com:443"

# elasticsearch.url: "http://35.190.198.240:9200"

# When this setting's value is true Kibana uses the hostname specified in the server.host

# setting. When the value of this setting is false, Kibana uses the hostname of the host

# that connects to this Kibana instance.

#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and

# dashboards. Kibana creates a new index if the index doesn't already exist.

#kibana.index: ".kibana"

# The default application to load.

#kibana.defaultAppId: "home"

kibana.defaultAppId: "dashboards"

# If your Elasticsearch is protected with basic authentication, these settings provide

# the username and password that the Kibana server uses to perform maintenance on the Kibana

# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

# is proxied through the Kibana server.

#elasticsearch.username: "user"

#elasticsearch.password: "pass"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.

# These settings enable SSL for outgoing requests from the Kibana server to the browser.

#server.ssl.enabled: false

#server.ssl.certificate: /path/to/your/server.crt

#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.

# These files validate that your Elasticsearch backend uses the same key files.

#elasticsearch.ssl.certificate: /path/to/your/client.crt

#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate

# authority for your Elasticsearch instance.

#elasticsearch.ssl.certificateAuthorities: [ "/path/to/your/CA.pem" ]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.

#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of

# the elasticsearch.requestTimeout setting.

#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value

# must be a positive integer.

#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side

# headers, set this value to [] (an empty list).

#elasticsearch.requestHeadersWhitelist: [ authorization ]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten

# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.

#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.

#elasticsearch.shardTimeout: 30000

# Time in milliseconds to wait for Elasticsearch at Kibana startup before retrying.

#elasticsearch.startupTimeout: 5000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.

#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.

#pid.file: /var/run/kibana.pid

# Enables you specify a file where Kibana stores log output.

#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.

#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.

#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information

# and all requests.

#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance

# metrics. Minimum is 100ms. Defaults to 5000.

#ops.interval: 5000

# The default locale. This locale can be used in certain circumstances to substitute any missing

# translations.

#i18n.defaultLocale: "en"

The problem occours only when i use the code for development . When i run the kibana-oss build using the same elasticsearch url with the same kibana config.yml . The application works fine


(Christian Dahlqvist) #4

If the Kibana you are running is the default distribution that includes X-Pack the server must also support X-Pack, which AWS ES service does not. That might be why you can only use the OSS Kibana distribution.


(Jagadeesh Kumar Ck) #5

Hii

i am running kibana in the oss mode

i am using the command

yarn start --oss

it will run kibana in the oss mode right?


(kulkarni) #6

correct, To start Kibana with only open-source code:

yarn start --oss

plz check the contributing guide here: https://github.com/elastic/kibana/blob/master/CONTRIBUTING.md

Cheers
Rashmi


(system) closed #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.