[Beat Monitoring] Beat name is differ with state

Hi. Thanks for your attention.
metricbeat.yml

name: "sample"

metricbeat.log

2021-09-03T14:46:12.876+0900    INFO    [publisher]     pipeline/module.go:113  Beat name: sample

curl state

[root@ip-01-02-03-04 15:00:04 metricbeat]# curl 127.0.0.1:5066/state
{"beat":{"name":"ip-01-02-03-04.ap-northeast-2.compute.internal"},"host":{"architecture":"x86_64","containerized":"containerized","hostname":"ip-01-02-03-04.ap-northeast-2.compute.internal","id":"----","os":{"codename":"Karoo","family":"redhat","kernel":"4.14.193-149.317.amzn2.x86_64","name":"Amazon Linux","platform":"amzn","version":"2"}},"management":{"enabled":false},"module":{"count":3,"names":["beat","kibana"]},"monitoring":{"cluster_uuid":"----"},"output":{"batch_size":50,"clients":1,"name":"elasticsearch"},"outputs":{"elasticsearch":{"cluster_uuid":"----"}},"queue":{"name":"mem"},"service":{"id":"----","name":"metricbeat","version":"7.13.4"}}

Why differ beat name?
I want change beat name for kibana's monitoring page.

This is a bug. Could you please open an issue on GH? https://github.com/elastic/beats/issues/new

Thanks!
GH : https://github.com/elastic/beats/issues/27755