Can indices.cache.filter.size be set dynamiclly?


(Makeyang) #1

I'd like modified the default 10% to 20%. So I'd like to ask so.


(Daniel Mitterdorfer) #2

Hi makeyang,

the setting indices.cache.filter.size is deprecated and you should use indices.queries.cache.size with 2.0 and above instead. As you can see in the docs indices.queries.cache.size is static.

Daniel


(Makeyang) #3

what is the status for 1.7?


(Daniel Mitterdorfer) #4

Hi makeyang,

indices.cache.filter.size is a node-level setting in 1.7 and only statically configurable.

Daniel


(Makeyang) #5

thanks.
don't get why make it statically. it's hard to evaluate its usage and online modification is really a useful feature.


(Daniel Mitterdorfer) #6

Hi,

this is a setting that you shouldn't have to modify really often. Moreover, if we make this a dynamic setting, we'd introduce additional complexity (and the likelihood of bugs increases). This and the fact that this setting is only seldom changed was probably the reason for making this a static setting in the first place.

But you're free to create a Github issue though. :slight_smile:

Daniel


(Wang Zhong) #7

Hi, what about es1.2.1? Is the indices.cache.filter.size also a static setting? But i have set it by cluster setting, it made sense. Am i doing something wrong?


(Daniel Mitterdorfer) #8

Hi,

I am not aware that this has ever been a dynamic setting. Can you paste the specific CURL command you've used to change this setting and the response you've got?

Daniel


(Wang Zhong) #9

Hi, i have got the dynamic setting in here:
https://www.elastic.co/guide/en/elasticsearch/reference/1.7/cluster-update-settings.html

and i do like this, then the setting works.

curl -XPUT 'http://localhost:9200/_cluster/settings' -d '{
"transient" : {
"indices.cache.filter.size" : "30%"
}
}'


(Makeyang) #10

it works. thanks wang_zhong


(Daniel Mitterdorfer) #11

Hi,

ah, you're right. I was mistaken regarding 1.7. This works in 1.7.3.

But just as a heads-up, if you try to update the corresponding setting indices.queries.cache.size with the cluster settings API in Elasticsearch 2.1.1, you'll get an acknowledge back but in the logs you'll find:

[WARN ][action.admin.cluster.settings] [Boomer] ignoring transient setting [indices.queries.cache.size], not dynamically updateable

Daniel


(system) #12