Can not get to security setting in kibana on a basic licence

Hi guys,

So under management in Kibana I cannot seem to get to any of the security settings (the option does not appear in the menu). I have enabled xpack security settings.

If I go through the dashboard to security this is what appears:

Any ideas?
Thanks!

HI,
As the error suggests in the screenshot, the user does not have enough permissions to access users. The security features provide a role-based access control (RBAC) mechanism, which enables you to authorize users by assigning privileges to roles and assigning roles to users or groups. You can create a superuser to login to see how to access users and roles. You can read about it more here:

https://www.elastic.co/guide/en/elastic-stack-overview/current/authorization.html

Thanks
Rashmi

Hi Rashmi,

Is there a way to see who I am logged in as? I haven't had to log in and so I don't even know how to grant this user account superuser rights.

Thanks! :slight_smile:

What kind of license is this stack on ?

https://www.elastic.co/guide/en/elasticsearch/reference/current/get-license.html

Thanks
Rashmi

The basic licence.

Thanks,
EJ

"status" : "active"
"type" : "basic"

Plz enable Security on your basic license to get access to users and roles. https://www.elastic.co/guide/en/elastic-stack-overview/current/get-started-enable-security.html

Thanks
Rashmi

I have already done this, in the elasticsearch.yml file I have the line:
xpack.security.enabled: true

But this has not worked.

Thanks,
EJ

Have you completed the entire exercise like setting up passwords for built in users ?

Set the built-in users' passwords.

Run the following command from the Elasticsearch directory:

./bin/elasticsearch-setup-passwords interactive

Please follow the link I sent above to configure security .

Thanks
Rashmi

We have tried that, it has already been done once. But if we try to run it again we get a message saying X-Pack Secuirty is not available. Which is odd because we have enabled it.

Thanks,
EJ

Hey @Ej_R,

You can find the user you're logged in as by navigating to the top right of Kibana and clicking the circle:

Can you post your full kibana.yml, redacting any sensitive information such as passwords?

Hiya,
My display looks slightly different to yours:

I shall post the yml file as well.

You are using version 6.6.2, in which security is not part of the basic license. You will need to upgrade to 6.8.

Okay, how do I go about this? Can I just upgrade or are there any requirement before upgrade?

I have upgraded both Kibana and elastic search to 7.2 but it is now coming up with:
image

Any ideas on what is causing this? I have used the curl command to check if elastic search is running, and have worked out it only runs when I get rid of the enable xpack security line. So I can't configure security at the moment (not that it currently matters as I can't even get onto the kibana dashboard)

Thanks,
EJ

Hey @Ej_R, how long has Kibana been in this state? Can you post your full kibana log file?

Hi Larry,
Since I upgraded it today to 7.2i I'll post it now.

Hiya,

I just checked the Kibana file and we did not have logging enabled.

Ok, please enable logging, and restart the Kibana process. You can use the logging.dest setting to specify a file where Kibana should log to. While you're at it, set logging.verbose: true in your kibana.yml too. That will give us the most information so that we can help you further.

I have enabled it, restarted the service but I am waiting for logs to appear.

Thanks!
EJ :slight_smile: