Cannot access Kibana remotely or on local machine

I have installed ES in a 3 node cluster. I have Kibana on #3 as well. ES is running fine as far as I can tell. Kibana installed and started fine. I have edited the .yml file with the following

Contents of kibana.yml
server.port: 5601 "" "name"
elasticsearch.hosts: ["http://localhost:9200"]

I have checked for a listener
[clintd@pdxelastictest03 kibana]$ netstat -nat | grep 5601

tcp 0 0* LISTEN
[clintd@pdxelastictest03 kibana]$ netstat -nat | grep 9200
tcp6 0 0 :::* LISTEN
tcp6 0 0 ::1:9200 :::* LISTEN

Attempted to connect from the local machine
[clintd@pdxelastictest03 kibana]$ curl ''
curl: (7) Failed connect to; Connection refused

Found this in the logs:
[clintd@pdxelastictest03 kibana]$ vi kibana.stderr

FATAL Error: Port 5601 is already in use. Another instance of Kibana may be running!

I don't see anything that would suggest Kibana is running anywhere else. I am at a loss. Anyone have ideas that would help me?

Which OS are you running? You might try lsof -i :5601 without kibana running to try to determine whether another process is using 5601.

That didn't return any values.

What kind of cluster are you running? How are you starting the instances?

I'm afraid I don't understand the question. I have 3 nodes running ES, I edited the .yml files for each indicating their partners and manually started each one.

It sounds like something is trying to start kibana more than once in one of your environments. Are you using a cloud provider? Kubernetes or something similar, etc?

It is an on-prem set up. I only have Kibana set up on server #3. I have tried to find anything like it trying to start Kibana twice, or anything else that would claim 5601 but no dice.

Are you starting kibana manually from the command line? If so, what command are you running?

sudo systemctl start kibana

Curious if you've made any progress. What does your kibana.service file look like?

No, I have not made any progress unfortunately / fortunately. I am out on vacation for the next 6 days. I will post my file when I return. TY for following up with me.


server.port: 5601 "" "name"
elasticsearch.hosts: ["http://localhost:9200"]

You are telling Kibana to look for himself as an elastic hosts.

server.port: 5601 "" "name"
elasticsearch.hosts: ["http://YourElasticHost1:9200", "http://YourElasticHost2:9200"]

Also, since you are running machines, if you are on CentOS7, make sure you have authorized access through your firewall. Test firewall-cmd --permanent --add-port=5601/tcp, then --reload.

I attempted that and still no luck. Output below:
.yml file details-
server.port: 5601 "" "name"
elasticsearch.hosts: ["http://hostname01:9200, "http://hostname02:9200"]

firewall-cmd --permanent --add-port=5601/tcp


systemctl stop kibana

systemctl start kibana

systemctl status kibana

● kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2019-09-09 08:52:54 PDT; 36ms ago
Main PID: 6594 (node)
CGroup: /system.slice/kibana.service
└─6594 /usr/share/kibana/bin/../node/bin/node --no-warnings --max-http-header-...


curl: (7) Failed connect to; Connection refused

Apologies for letting this drop, did you ever solve it? If not, lets take another swing at it.


No, I was unable to resolve this. After attempting to get the communication to work with the cluster I decided to try and simplify. I uninstalled ES and Kibana one the node in question, then reinstalled as a single node deployment with the intent, that if I could get it working as a single node I could add the other cluster members later. This seemed to help somewhat, but now I receive a notice when attempting to browse to my kibana IP address that, "The Kibana server is not ready."
I am not working through this, but seem stalled again.

I have resolved this. How do I close it?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.