Cannot add geo_point type to the mapping template


(Vitaly) #1

Hi,
I'm trying to copy my mapping template from my 5.3 ELK cluster to the new 5.3.2 instance.
Any ideas what this error message is meaning?

TIA, Vitaly

 curl -XPUT 'localhost:9200/_template' -H 'Content-Type: application/json' -d @template-new.json
{
  "error" : {
    "root_cause" : [
      {
        "type" : "illegal_argument_exception",
        "reason" : "unknown setting [index.logstash.mappings._default_.properties.geoip.properties.location.type] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"
      }
    ],
    "type" : "illegal_argument_exception",
    "reason" : "unknown setting [index.logstash.mappings._default_.properties.geoip.properties.location.type] please check that any required plugins are installed, or check the breaking changes documentation for removed settings"
  },
  "status" : 400
}

My template is:

   {
  "logstash" : {
    "order" : 0,
    "template" : "logstash*",
    "settings" : {
      "index" : {
        "number_of_shards" : "1",
        "number_of_replicas" : "0"
      }
    },

    "mappings" : {
      "_default_" : {
       "properties" : {
         "geoip" : {
           "properties" : {
              "location" : {
                "type" : "geo_point"
               }
            }
          }
         }
        }
     },

    "aliases" : { }
  }
}

(Mark Walkom) #2

Can you update your post with code formatting on the response, it's hard to read as is.
Also please show the entire template file.


(Vitaly) #3

Mark, thank you - I updated my post.
Vitaly


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.