Cannot connect to the Elasticsearch cluster currently configured for Kibana


(Joan) #1

I am not able to connect Kibana with elasticsearch. Here is my elasticsearch file config:

cluster.name: laboratori
node.name: node-1
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch

and my kibana.yml has nothing (everything is commented).

If I try a curl to the elastisearch url, it responds:
{
"name" : "node-1",
"cluster_name" : "laboratori",
"cluster_uuid" : "fNCQ7ByMRfaDLqe0wyQv6g",
"version" : {
"number" : "6.4.0",
"build_flavor" : "default",
"build_type" : "rpm",
"build_hash" : "595516e",
"build_date" : "2018-08-17T23:18:47.308994Z",
"build_snapshot" : false,
"lucene_version" : "7.4.0",
"minimum_wire_compatibility_version" : "5.6.0",
"minimum_index_compatibility_version" : "5.0.0"
},
"tagline" : "You Know, for Search"
}

but the Kibana says "Cannot connect to the Elasticsearch cluster currently configured for Kibana."

And if I check the kibana.stdout I see the message:

{"type":"log","@timestamp":"2018-09-17T18:17:05Z","tags":["warning","elasticsearch","admin"],"pid":3768,"message":"Unable to revive connection: http://localhost:9200/"}
{"type":"log","@timestamp":"2018-09-17T18:17:05Z","tags":["warning","elasticsearch","admin"],"pid":3768,"message":"No living connections"}

Could someone help me?

Regards,
Joan


(kulkarni) #3

I see this post was withdrawn...if still an issue..plz report back..

Thanks
Rashmi


(Joan) #4

withdrawn? Why? It is still and issue


#5

Can you post your entire elasticsearch.yml and kibana.yml configurations? Also, are they both on the same host (single node)?


(Joan) #6

Yes, they are on the same node.

[root@demo ~]# grep -v ^# /etc/elasticsearch/elasticsearch.yml
cluster.name: laboratori
node.name: node-1
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch

The kibana.yml is all commented, so no parameter setted.

Thanks and regards


(Joan) #7

Hi all!

I checked the /var/log/kibana/kibana.stdout and I found the following error

{"type":"log","@timestamp":"2018-09-20T14:24:40Z","tags":["error","elasticsearch","admin"],"pid":10119,"message":"Request error, retrying\nHEAD http://loc
alhost:9200/ => connect ECONNREFUSED 172.22.249.102:9200"}

I did not understand why the localhost was translated to my IP 172.22.249.102. I went to /etc/hosts and changed the resolution to 127.0.0.1. Now it works like a charm


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.