Cannot get curator to rollover an index

I have a feeling there is going to be a forehead slapping moment here, but anyways... I am trying to rollover indexes based on size, and I cannot get it to work. The alias name I want to rollover is logstash-production, and 'GET _alias/logstash-production' shows there is an index with that alias.

  "logstash-production-000001": {
    "aliases": {
      "logstash-production": {}

The curator configuration includes

    action: rollover
    description: >-
      Rollover production samples every 1 GB
      name: logstash-production
        max_size: 1gb
        index.number_of_shards: 2
        index.number_of_replicas: 0

As of this morning the index is 4.9 GB. I set the loglevel to DEBUG and blacklist: [] and all I get when curator runs is this. None of the voluminous output I get when my aged-based yml is run.

2018-04-30 09:45:02,119 DEBUG                curator.cli                    run:108  Client and logging options validated.
2018-04-30 09:45:02,119 DEBUG                curator.cli                    run:112  default_timeout = 30
2018-04-30 09:45:02,119 DEBUG                curator.cli                    run:116  action_file: /home/elasticsearch/.curator/rolloverIndices.yml

elasticsearch 6.2.3, curator 5.5.1.

If it's stopping there, it is likely that there is something misformatted in your YAML file. It's attempting to read the file, and not able to go farther.

Perhaps put in the entire YAML config file here, and we can look it over. Double-check the indentation and colons and all that formatting stuff.

Yes, index.number_of_replicas is indented by 8 spaces, and vim had auto-indented it using a tab. It is now working. Thanks!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.