Curator Rollover not working


(Lance) #1

ES version - 6.3.2
Curator version - 5.5.4
Installed Curator from RPM on RHEL7

My Curator file:

actions:
  1:
    action: rollover
    description: >-
      Rollover the index associated with alias 'index_prod_active', which should be in the
      form of prefix-000001 (or similar), or prefix-YYYY.MM.DD-1.
    options:
      name: index_prod_active
      conditions:
        max_age: 1d
        max_size: 480gb

Output:
Preparing Action ID: 1, "rollover"

Issue the index rollover action is not performed. I can curl the index_prod_active/_rollover api with the same settings and it will rollover. Other curator actions in other files work as expected.


(Lance) #2

Here is output from Debug loglevel with verify_certs=False for debugging purposes:


(Aaron Mildenstein) #3

/etc/elasticsearch/curator.conf and index_prod_rollover.curator Shouldn't these end in.yml? Just a syntactic thing for me.

You can run this with --dry-run and it will show the dry run output, just like the rollover API does. Because it never gets past the client connection, though, it seems like there might be an issue there. Everything else seems to have validated properly, schema-wise.


(Lance) #4

Since I am specifying the filenames to load they do not have to be .yml

I get the same message when using --dry-run.


(Aaron Mildenstein) #5

Yes, but did you set the logging to be:

logging:
  # ... other options
  blacklist: []

(Lance) #6

Someone had changed the password for the user in ES & SG that was being used to run the curator script. The server was sending back an empty reply, I found this by building the curl with all the parameters from curator.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.