Cannot select host on System Overview after upgrade to 6.6.0


#1

Hello,

After upgrade from 6.5.0 to 6.6.0 I cannot select host on System Overview page by double click to view Host Overview data. Filter field is empty. Anyway, I can apply filter manually, but how I can fix this?
Thank you in advance.

Evgeny.


(Mario Castro) #2

Hi @carrion

Please, can you share more details about the entire stack. I'm trying with 6.6.0 and I don't see problems. It might be a version mismatch but we aren't aware of anything like this


#3

Hi Mario,

Thank you for your answer!
I'm new to the Elastic stack, the Elastic stack has been upgraded from 6.5.0 to 6.6.0. Metricbeat has also been upgraded to 6.6.0 on all clients.
Everything works except double clicking on the host name in System Overview dashboard. The Host Overview dashboard opens but without "beat.name" filter (filter is empty).
This is mostly default installation, only Elastiflow is also added.
Please let me know what details are needed additionally.


#4

Hi

I too am having this issue on 6.6.0 and now 6.6.1. The [Metricbeat System] Overview does not double click to the desired host instead goes to [Metricbeat System] Host overview. This was working and used daily without an issue.

Is there a was to reset the Metricbeat Dashboards? Have run metricbeat setup --dashboards but results still the same

regards

Ed


(Mastah) #5

Hi,

I'm having the same issue. Kibana is 6.6.1, metricbeat is 6.6.1, logstash is 6.6.1
The double "click" thing doesn't work, each time I click on an host, I'm directly redirected to the Host overview dashboard with no filter and all data from all host aggregate.
I have to manual filter the host name to get the dashboard to show only the result for one host.

My stack is the following :

metricbeat output.redis => redis => input.redis logstash output.elasticsearch => ealsticsearch (with index template) <= kibana (with dashboard)

Regards.


(ruflin) #6

I tested this locally with 6.6 without the migration part and it seems when I click on "Host" it adds the query but when I click on the link, it just takes all as you described above. So this seems to be a regression in 6.6.

Could one of you file an issue in https://github.com/elastic/beats ?


(Mastah) #7

Done ^^


(ruflin) #8

Thanks for filing. We will follow up there.