Cannot setup kibana dashboards


#1

I have the following set in my metricbeat.yml

setup.kibana:
  host: "localhost:5601"
  protocol: "https"
  ssl.enabled: true
  ssl.certificate_authorities: [ "/etc/opt/zookeeper/MyCorporateCA.pem" ]
  ssl.verification_mode: none

When I run "cd /etc/metricbeat; /usr/share/metricbeat/bin/metricbeat setup --dashboards" (I run it from there because otherwise it cannot find metricbeat.yml) then I get

Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing directory /usr/share/metricbeat/bin/kibana: No directory /usr/share/metricbeat/bin/kibana/6

which is right, they are under /usr/share/metricbeat/kibana/6, not /usr/share/metricbeat/bin/kibana/6. Am I missing something, or is it just a bug. This is with 6.2.0


(Adrian Serrano) #2

You should run it from /usr/share/metricbeat and pass the -c /etc/metricbeat/metricbeat.yml argument. I think that will suffice.

If you look at the /etc/init.d/metricbeat script, you'll see it passes a few more paths:

-path.home /usr/share/metricbeat
-path.conf /etc/metricbeat
-path.data /var/lib/metricbeat
-path.logs /var/log/metricbeat

With those you don't need to change to any particular directory before running metricbeat.


#3

Not quite, I still get the same error when doing that. However the following works

bin/metricbeat -c /etc/metricbeat/metricbeat.yml \
    -path.home /usr/share/metricbeat \
    -path.config /etc/metricbeat \
    -path.data /var/lib/metricbeat \
    setup --dashboards

(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.